Bug 310048 - Cannot copy files to root of MTP device
Summary: Cannot copy files to root of MTP device
Status: RESOLVED FIXED
Alias: None
Product: kio
Classification: Unclassified
Component: mtp (show other bugs)
Version: Git
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Philipp Schmidt
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-13 19:21 UTC by Kai Uwe Broulik
Modified: 2012-11-15 10:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2012-11-13 19:21:10 UTC
[KIO MTP]

When I try to copy files onto the Root of my Galaxy Nexus (ie. the "Internal Storage") folder, it says "Cannot copy file: Internal Storage is a file, but a folder was expected." Copying files in any subfolder works totally fine but copying to the root "Internal Storage" doesn't work.

Reproducible: Always

Steps to Reproduce:
1. Use Android device with MTP, plug in
2. Select "Portable media player" or whatever entry it gets in the Places panel
3. Click "Internal Storage"
4. Copy a file in that directory
Actual Results:  
Cannot because of error above

Expected Results:  
File copied :)
Comment 1 Philipp Schmidt 2012-11-15 09:31:05 UTC
Yep, can reproduce it here. Should be a minor thing. Stay tuned.
Comment 2 Philipp Schmidt 2012-11-15 10:25:09 UTC
Git commit ebd091f3021a359a2654124c2df3d2d73fb431ee by Philipp Schmidt.
Committed on 15/11/2012 at 11:22.
Pushed by schmidt into branch 'master'.

Fixes storages not being recognized as valid destinations when copying
to the device. Also added some more sane debug information.

M  +32   -8    kio_mtp.cpp
M  +9    -2    kio_mtp_helpers.cpp

http://commits.kde.org/kio-mtp/ebd091f3021a359a2654124c2df3d2d73fb431ee