Bug 308314 - System Preferences button only works once
Summary: System Preferences button only works once
Status: RESOLVED FIXED
Alias: None
Product: print-manager
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Daniel Nicoletti
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-13 02:34 UTC by Robin Perkins
Modified: 2013-01-17 02:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robin Perkins 2012-10-13 02:34:53 UTC
In the KDE control panel, clicking on the System Preferences button show the four checkbox options. Clicking on it again works fine.

However, after clicking on 'Overview' and going into another control panel (e.g. Sharing), then going back to 'Overview' and back into Printers clicking on the System Prefences button again gives the error prompt "Failed to get server settings. Details: Not Modified"

Closing the System Settings and opening again lets it work again.

Reproducible: Always

Steps to Reproduce:
As per details
Actual Results:  
As per details


Using the packages in Kubuntu 12.10 Beta 2
Comment 1 Daniel Nicoletti 2012-10-15 14:40:27 UTC
I know the bug and I think I've already fixed it, can you please try the git version?
Comment 2 Daniel Nicoletti 2013-01-17 02:47:43 UTC
Git commit 03250ca3e9e1f069f13c22099bb63bd4d9fc1078 by Daniel Nicoletti.
Committed on 17/01/2013 at 03:46.
Pushed by dantti into branch 'KDE/4.10'.

Rely on cupsAdminGetServerSettings() return value to know if the request went fine since it might just read the local file

M  +1    -8    libkcups/KCupsConnection.cpp
M  +0    -9    libkcups/KCupsConnection.h
M  +27   -17   libkcups/KCupsRequest.cpp
M  +3    -1    libkcups/KCupsRequest.h
M  +0    -11   printer-manager-kcm/PrintKCM.cpp
M  +0    -1    printer-manager-kcm/PrintKCM.h

http://commits.kde.org/print-manager/03250ca3e9e1f069f13c22099bb63bd4d9fc1078