Bug 307981 - Support Amazon MP3 downloads in Italy and Spain
Summary: Support Amazon MP3 downloads in Italy and Spain
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Services/Amazon MP3 Store (show other bugs)
Version: 2.6-git
Platform: unspecified All
: NOR wishlist (vote)
Target Milestone: 2.7
Assignee: Amarok Developers
URL: http://www.amazon.it/b/ref=sa_menu_mp...
Keywords:
: 308664 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-10-06 17:22 UTC by Michele Valzelli
Modified: 2012-10-19 15:26 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.7


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michele Valzelli 2012-10-06 17:22:05 UTC
Recently Amazon launched its Mp3 store in Italy. It would be nice to see Amarok support amazon integration also for this country.

Reproducible: Always
Comment 1 Sven Krohlas 2012-10-06 19:22:37 UTC
Thanks for the info. Expect it in Amarok 2.7.
Comment 2 Sven Krohlas 2012-10-07 09:59:37 UTC
Just checked: Amazon.es now also has a MP3 downloads section.
Comment 3 Sven Krohlas 2012-10-14 23:48:41 UTC
Git commit ff8265da71fa4a811338f27b5dba38bf810da493 by Sven Krohlas.
Committed on 15/10/2012 at 01:41.
Pushed by krohlas into branch 'master'.

Amazon store: Support for Amazon MP3 in Italy and Spain

Checkout does not work yet, we need to be verified by Amazon first. That
should be a matter of a few days and does not require any changes in
Amarok.

So now we support: USA, Great Britain, France, Spain, Italy, Japan,
Germany, Austria and Switzerland

We might support Andorra, Vatican and Portugal too, with the new
locales. So if anyone living in those countries could test the store
(once the new ones have been verified by Amazon) it would be great.

I always wanted to hear some words from the pope about free software. ;-)
FIXED-IN:2.7
DIGEST: Support for Amazon MP3 in Spain and Italy

M  +1    -0    ChangeLog
M  +2    -2    src/services/amazon/Amazon.h
M  +14   -10   src/services/amazon/AmazonConfig.h
M  +10   -0    src/services/amazon/AmazonConfigWidget.ui
M  +27   -11   src/services/amazon/AmazonSettingsModule.cpp
M  +2    -0    src/services/amazon/AmazonSettingsModule.h
M  +3    -1    src/services/amazon/AmazonStore.cpp
M  +10   -0    src/services/amazon/AmazonWantCountryWidget.ui

http://commits.kde.org/amarok/ff8265da71fa4a811338f27b5dba38bf810da493
Comment 4 Sven Krohlas 2012-10-19 15:26:20 UTC
*** Bug 308664 has been marked as a duplicate of this bug. ***