Bug 307670 - QML notifications do not show title on popup notification
Summary: QML notifications do not show title on popup notification
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: notifications (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords: regression, reproducible
: 311339 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-10-01 13:00 UTC by Kai Uwe Broulik
Modified: 2012-12-24 09:38 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2012-10-01 13:00:14 UTC
When a notification appears, a popup is shown. This popup, however, does not show the notification title. The notification title is shown int he history, though.

Reproducible: Always

Steps to Reproduce:
1. kdialog --passivepopup "foo" --title "bar"
2.
3.
Actual Results:  
A notification "foo" appears

Expected Results:  
A notification "foo" with title "bar" appears
Comment 1 Myriam Schweingruber 2012-10-11 12:03:29 UTC
Kai-Uwe: version, please!
Comment 2 Kai Uwe Broulik 2012-10-11 12:04:57 UTC
When were QML notifications introduced? Right. For 4.10 in current master. And which version is not listed in the version popup? Right. 4.10 master.
Comment 3 Cédric Bellegarde 2012-12-06 17:47:40 UTC
Can confirm the bug!

It really need to be fixed, many application show empty notifications because of missing title... Gwenview for exemple show notifications with a title and an open button.
Comment 4 Yichao Yu 2012-12-15 13:40:40 UTC
Can confirm here. The title was actually shown at first (right after I upgrade to 4.9.90) but somehow disappear later.....
Comment 5 Cédric Bellegarde 2012-12-20 15:07:35 UTC
https://bugs.kde.org/show_bug.cgi?id=311339
Comment 6 Weng Xuetian 2012-12-24 04:28:05 UTC
Git commit 579b860460dcd5c54352fb0a4201ece955b2433b by Weng Xuetian.
Committed on 24/12/2012 at 05:26.
Pushed by xuetianweng into branch 'master'.

add summary back to last notification, with fixing some layout bug
REVIEW: 107743

M  +89   -58   plasma/generic/applets/notifications/contents/ui/LastNotificationPopup.qml
M  +1    -1    plasma/generic/applets/notifications/contents/ui/NotificationDelegate/NotificationDelegate.qml

http://commits.kde.org/kde-workspace/579b860460dcd5c54352fb0a4201ece955b2433b
Comment 7 Weng Xuetian 2012-12-24 09:38:04 UTC
*** Bug 311339 has been marked as a duplicate of this bug. ***