Bug 307498 - The product networkmanagement_configshell does not exist or you aren't authorized to enter a bug into it
Summary: The product networkmanagement_configshell does not exist or you aren't author...
Status: RESOLVED DUPLICATE of bug 304588
Alias: None
Product: drkonqi
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-27 20:26 UTC by Anton Samsonov
Modified: 2012-12-17 16:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Samsonov 2012-09-27 20:26:10 UTC
Upon submitting crash report against NetworkManager Settings Editor, instead of final confirmation, an HTML error page was displayed:

There was an unhandled Bugzilla error: Unknown error
Sorry, either the product networkmanagement_configshell does not exist or you aren't authorized to enter a bug into it.
Please press Back and try again.

Retrying didn't help. Moreover, with each try, a new window for HTML error page was created and, although I closed such window by pressing the X control button every time, the next time all the N+1 windows were popped up.

Reproducible: Sometimes

Steps to Reproduce:
I don't know how to reproduce it. Due to the fact that my original reported crash was easily reproduced, I spawned another instance of DrKonqi and was able to submit the report without problems. But then I switched back to the first instance and retried once more, and still got the same error page.

My guess was that the problem could be connected with Bugzilla authentication expiration, because it took me considerable time to write the original report, while on the second time I just copied it. But now I see that the HTML error page actually contains "Log out mymail@mail.tld" link, so the hypothesis is not approved.
Actual Results:  
To summarize, on the very first try, an error message was displayed saying that product "networkmanagement_configshell" didn't exist, or I wasn't allowed to post bug reports against it. On the second try in a separate instance of DrKonqi with another identical backtrace and copy-pasted description, everything went fine, concluding in success confirmation. On the following retry in the first DrKonqi instance, the error continued to happen, each time spawning one more HTML browser window.

Expected Results:  
I expected successful report submission on first try, or at least after retrying, especially if nothing was going wrong with the Bugzilla service itself.

$ /usr/lib64/kde4/libexec/drkonqi -v
Qt: 4.8.1
KDE Development Platform: 4.8.5 (4.8.5) "release 2"
The KDE Crash Handler: 2.1.5 (this version does match neither 2.0 nor 2.9.2 options in the list here)

$ uname -a
Linux myhost.mydom.tld 3.4.6-2.10-desktop #1 SMP PREEMPT Thu Jul 26 09:36:26 UTC 2012 (641c197) x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Anton Samsonov 2012-09-27 20:31:49 UTC
Oh, it seems that this is the same as bug #304588 -- didn't found it on first try because of odd title.

*** This bug has been marked as a duplicate of bug 304588 ***
Comment 2 Jekyll Wu 2012-12-17 16:26:17 UTC
Git commit 11ef70ebabd833c7e4926d2096bbbb9342328bda by Jekyll Wu.
Committed on 17/12/2012 at 17:09.
Pushed by jekyllwu into branch 'master'.

Add mapping for networkmanagement_configshell

M  +1    -0    drkonqi/data/mappings

http://commits.kde.org/kde-runtime/11ef70ebabd833c7e4926d2096bbbb9342328bda