Bug 306118 - Canvas has an offset after stopping presentation
Summary: Canvas has an offset after stopping presentation
Status: RESOLVED FIXED
Alias: None
Product: calligrastage
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: T Zachmann
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-01 08:05 UTC by T Zachmann
Modified: 2012-09-01 10:42 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description T Zachmann 2012-09-01 08:05:21 UTC
When running a presentation that does not fill the full screen e.g. due to screen ratio and slide ratio do not match and the presentation is stopped during the presentation there can be an offset in the slide after the presentation mode is left. The offset happens only if the zoom level is smaller then the screen or it is fit to screen/fit to width. Zooming in fixes the problem once the slide is bigger then the screen.

Reproducible: Always

Steps to Reproduce:
1. Set zoom level to fit to screen on a slide that has a different ratio then the screen
2. Start a presentation
3. Press Esc to leave the presentation mode

Actual Results:  
The slide shown has an offset

Expected Results:  
The slide should not have an offset
Comment 1 T Zachmann 2012-09-01 08:10:29 UTC
Git commit a184af1641c2d14907a6a0a6c05081d8dad921b2 by Thorsten Zachmann.
Committed on 01/09/2012 at 10:07.
Pushed by zachmann into branch 'master'.

Fix unwanted offset after cancel slide show.

When running a presentation that does not fill the full screen e.g. due to
screen ratio and slide ratio do not match and the presentation is stopped
during the presentation there can be an offset in the slide after the presentation
mode is left. The offset happens only if the zoom level is smaller then the screen
or it is fit to screen/fit to width. Zooming in fixes the problem once the slide
is bigger then the screen.

M  +2    -0    stage/part/KPrViewModePresentation.cpp

http://commits.kde.org/calligra/a184af1641c2d14907a6a0a6c05081d8dad921b2
Comment 2 T Zachmann 2012-09-01 10:42:00 UTC
Git commit a12f5ec5e9921a6a13601f8cde821b27bdf95960 by Thorsten Zachmann.
Committed on 01/09/2012 at 10:07.
Pushed by zachmann into branch 'calligra/2.5'.

Fix unwanted offset after cancel slide show.

When running a presentation that does not fill the full screen e.g. due to
screen ratio and slide ratio do not match and the presentation is stopped
during the presentation there can be an offset in the slide after the presentation
mode is left. The offset happens only if the zoom level is smaller then the screen
or it is fit to screen/fit to width. Zooming in fixes the problem once the slide
is bigger then the screen.

M  +2    -0    stage/part/KPrViewModePresentation.cpp

http://commits.kde.org/calligra/a12f5ec5e9921a6a13601f8cde821b27bdf95960