Bug 306052 - visual glitches with oxyen-transparent and transparent konsole window
Summary: visual glitches with oxyen-transparent and transparent konsole window
Status: RESOLVED UNMAINTAINED
Alias: None
Product: Oxygen
Classification: Unclassified
Component: style (show other bugs)
Version: 4.9
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
: 306544 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-30 21:37 UTC by Marcel
Modified: 2018-09-05 00:14 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Window after klicking details button for one element (381.43 KB, image/png)
2012-11-06 01:08 UTC, Marcel
Details
window after some resizing, when it is ok (493.75 KB, image/png)
2012-11-06 01:09 UTC, Marcel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel 2012-08-30 21:37:03 UTC
If I use oxygen-transparent and a konsole profile with transparent background, the background has visual glitches since the upgrade to KDE 4.9. Some parts of the background are not transparent but simply black, other parts have some sort of "ghost characters" of other lines of the konsole. I'm using an intel system.

Reproducible: Sometimes
Comment 1 Hugo Pereira Da Costa 2012-09-11 20:37:53 UTC
yes ... can reproduce ...
will investigate
Comment 2 Hugo Pereira Da Costa 2012-09-11 22:30:22 UTC
Git commit f65d3588fd372f89257b0c81f25ce179d2896084 by Hugo Pereira Da Costa.
Committed on 12/09/2012 at 00:29.
Pushed by hpereiradacosta into branch 'master'.

Do not set opaque region behind konsole, since it breaks transparent themes.

M  +10   -12   style/oxygenblurhelper.cpp

http://commits.kde.org/oxygen-transparent/f65d3588fd372f89257b0c81f25ce179d2896084
Comment 3 Hugo Pereira Da Costa 2012-09-11 22:30:41 UTC
That fixes it. Thanks for reporting.
Comment 4 Jekyll Wu 2012-09-13 00:32:20 UTC
*** Bug 306544 has been marked as a duplicate of this bug. ***
Comment 5 Marcel 2012-09-13 16:35:07 UTC
Thanks, it is fixed in Konsole now, but sadly not in other Applications using Konsole KPart like Yakuake or Dolphin
Comment 6 Hugo Pereira Da Costa 2012-09-13 16:40:43 UTC
Ok. Reopening. Definitly needs more work ...
Comment 7 Marcel 2012-11-05 03:55:27 UTC
The GHNS-Windows (eg for plasmoids) has the same problem.
Comment 8 Hugo Pereira Da Costa 2012-11-05 06:22:37 UTC
Fixed ... sorry :(
Comment 9 Hugo Pereira Da Costa 2012-11-05 10:22:31 UTC
1/ ignore comment 8, that was meant for a different bug.
2/ concerning comment 7: 
Are we talking about: http://wstaw.org/m/2012/11/05/plasma-desktopwA5042.png ?
I see no issue with those, at least with latest oxygen-transparent code (committed this morning). Can you double check ? And/or send screenshot of the issue ? 
Thanks, 

Hugo
Comment 10 Marcel 2012-11-06 01:08:27 UTC
Created attachment 75044 [details]
Window after klicking details button for one element
Comment 11 Marcel 2012-11-06 01:09:34 UTC
Created attachment 75045 [details]
window after some resizing, when it is ok
Comment 12 Christoph Feck 2018-09-05 00:14:36 UTC
Oxygen-Transparent is unmaintained, so we unfortunately have to close all tickets.

Other style engines (QtCurve, Kvantum) might also offer transparency.