Bug 305792 - undo of shape creation broken: lead to crash
Summary: undo of shape creation broken: lead to crash
Status: RESOLVED FIXED
Alias: None
Product: calligrawords
Classification: Unclassified
Component: general (show other bugs)
Version: Git
Platform: Compiled Sources Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: Calligra Words Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-25 22:28 UTC by Sune Vuorela
Modified: 2012-12-14 23:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sune Vuorela 2012-08-25 22:28:40 UTC
1) create a document. 
2) write some characters. 
3) create a rectangle shape. 
4) undo the creation of the rectangle.
5) move(!) the rectangle a bit, and see it disappear. 
6) undo the rectangle move.  
7) crash.

Reproducible: Always
Comment 1 Camilla Boemann 2012-12-14 23:29:05 UTC
Git commit 89b253f6d07d5daf1af7e4b1c6359c7f4e73ed4b by C. Boemann.
Committed on 15/12/2012 at 00:27.
Pushed by boemann into branch 'master'.

So deleting shapes were not working since the part/document split

I had forgotten to do a connect. O well this fixes it

M  +1    -0    words/part/KWPart.cpp

http://commits.kde.org/calligra/89b253f6d07d5daf1af7e4b1c6359c7f4e73ed4b
Comment 2 Camilla Boemann 2012-12-14 23:30:37 UTC
Git commit 0119e9c28c4e384e5abc4be6042fd4724cbdc9a1 by C. Boemann.
Committed on 15/12/2012 at 00:27.
Pushed by boemann into branch 'calligra/2.6'.

So deleting shapes were not working since the part/document split

I had forgotten to do a connect. O well this fixes it

M  +1    -0    words/part/KWPart.cpp

http://commits.kde.org/calligra/0119e9c28c4e384e5abc4be6042fd4724cbdc9a1