Bug 304813 - kdesrc-build should give a clear error if kde-projects database download fails
Summary: kdesrc-build should give a clear error if kde-projects database download fails
Status: RESOLVED FIXED
Alias: None
Product: kdesrc-build
Classification: Unclassified
Component: general (show other bugs)
Version: 1.15.1
Platform: Fedora RPMs Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Michael Pyne
URL:
Keywords:
: 307989 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-08 18:48 UTC by koolstack
Modified: 2013-03-22 22:48 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 1.16


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description koolstack 2012-08-08 18:48:09 UTC
Unable to build KDE using kdesrc-build

Have errors:
1) no active modules to build!
2) Can't call method "phases" on an undefined value at /usr/bin/kdesrc-build line 6538

Reproducible: Always

Steps to Reproduce:
1. run kdesrc-build in home directory
Actual Results:  
 * Downloading projects.kde.org project database...
 * Module automoc is apparently XML-based, but contains no
active modules to build!
 * Module cagibi is apparently XML-based, but contains no
active modules to build!
 * Module attica is apparently XML-based, but contains no
active modules to build!
 * Module soprano is apparently XML-based, but contains no
active modules to build!
 * Module polkit-qt-1 is apparently XML-based, but contains no
active modules to build!
 * Module phonon/phonon is apparently XML-based, but contains no
active modules to build!
 * Module phonon-gstreamer is apparently XML-based, but contains no
active modules to build!
 * Module phonon-vlc is apparently XML-based, but contains no
active modules to build!
 * Module strigi/libstreams is apparently XML-based, but contains no
active modules to build!
 * Module strigi/libstreamanalyzer is apparently XML-based, but contains no
active modules to build!
 * Module strigi/strigiutils is apparently XML-based, but contains no
active modules to build!
 * Module strigi/strigidaemon is apparently XML-based, but contains no
active modules to build!
 * Module strigi/strigiclient is apparently XML-based, but contains no
active modules to build!
 * Module kdelibs is apparently XML-based, but contains no
active modules to build!
 * Module kactivities is apparently XML-based, but contains no
active modules to build!
 * Module kde-runtime is apparently XML-based, but contains no
active modules to build!
 * Module kde-workspace is apparently XML-based, but contains no
active modules to build!
 * Module kdeplasma-addons is apparently XML-based, but contains no
active modules to build!
 * Module kde-baseapps is apparently XML-based, but contains no
active modules to build!
 * Module kate is apparently XML-based, but contains no
active modules to build!
 * Module konsole is apparently XML-based, but contains no
active modules to build!
 * Module kde-build-metadata is apparently XML-based, but contains no
active modules to build!
Encountered an error in the execution of the script.
The error reported was Can't call method "phases" on an undefined value at /usr/bin/kdesrc-build line 6538.
 at /usr/bin/kdesrc-build line 6538
	main::expandXMLModules('ksb::BuildContext=HASH(0x1333ea0)', 'Module=HASH(0x133e288)', 'Module=HASH(0x133e4c8)', 'Module=HASH(0x133e678)', 'Module=HASH(0x1348de0)', 'Module=HASH(0x1348f90)', 'Module=HASH(0x133e798)', 'Module=HASH(0x13492c0)', 'Module=HASH(0x1349470)', ...) called at /usr/bin/kdesrc-build line 8591
	eval {...} called at /usr/bin/kdesrc-build line 8497

Please submit a bug against kdesrc-build on http://bugs.kde.org/


Expected Results:  
KDE should build or at least tell me what dependencies are missing in the cmake logs
Comment 1 Michael Pyne 2012-08-08 23:03:40 UTC
This is all crazy... however I think the underlying problem is that the XML database describing the KDE projects is corrupt or malformed somehow, because you shouldn't see error messages like "Module konsole is apparently XML-based, but contains no active modules to build!", as that is definitely a valid module.

I've just tried a run over here (which re-downloaded the XML file) and it seems to work OK.

So please find your local XML database file (should be ~/kdesrc/kde_projects.xml unless you moved the source directory somewhere else) and remove it. If kdesrc-build still has problems please let me know.

Also let me know if that works, so I can improve the error message in that case.
Comment 2 Christoph Feck 2012-08-09 00:14:50 UTC
The project.kde.org server is/was down, so it cannot download the projects.xml file.
Comment 3 koolstack 2012-08-09 18:39:41 UTC
Thanks guys.

As Mr. Feck has pointed out the server was down and as it is now working again I am able to build as expected.

I didn't delete any local files - I just ran kdesrc-build after the server returned to service.

Perhaps an error should be clearly shown to indicate that kdesrc-build is unable to contact the server...
Comment 4 Michael Pyne 2012-08-09 21:56:02 UTC
I agree that the error shown can be improved, reopening as a new bug.
Comment 5 Michael Pyne 2012-12-21 03:30:53 UTC
Git commit 8ad8eacadfcbff966e7a14151f297953ec7cc11d by Michael Pyne.
Committed on 21/12/2012 at 04:29.
Pushed by mpyne into branch 'master'.

kde-projects: Improve error message somewhat.

This improves the error message encountered with mal-formed XML in the
kde-projects database, at least a little bit.
FIXED-IN:1.16

M  +7    -2    kdesrc-build
M  +3    -1    modules/ksb/KDEXMLReader.pm

http://commits.kde.org/kdesrc-build/8ad8eacadfcbff966e7a14151f297953ec7cc11d
Comment 6 Michael Pyne 2012-12-21 03:36:36 UTC
*** Bug 307989 has been marked as a duplicate of this bug. ***
Comment 7 Mike Perik 2013-03-22 18:55:16 UTC
Has the issue with the kde_projects.xml data being incomplete been resolved.  I cannot build kde with kdesrc-build due to http://projects.kde.org/kde_projects.xml being incomplete.
Comment 8 Michael Pyne 2013-03-22 22:48:56 UTC
The source code repositories are currently undergoing emergency maintenance which has led to the kde_projects.xml data generator giving invalid XML output.

I'd recommend trying again tomorrow, or you can follow http://identi.ca/kdesysadmin to see what the current status is.