Bug 304707 - proxy configuration does not work with environment variables
Summary: proxy configuration does not work with environment variables
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_proxy (show other bugs)
Version: 4.9.3
Platform: OpenSUSE Linux
: NOR grave (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-07 06:34 UTC by Mathias Homann
Modified: 2013-10-06 13:25 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.3


Attachments
Proxy configuration (14.68 KB, image/png)
2013-05-20 10:41 UTC, Marian Kyral
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Homann 2012-08-07 06:34:40 UTC
I have a proxy set up "the usual way", with $http_proxy containing the proxy url, and $no_proxy containing the exceptions list.

When I set KDE to use "system proxy settings", KDe apps (e.g. konqueror) don't use the proxy

Reproducible: Always

Steps to Reproduce:
1. setup privoxy on localhost
2. point the system at privoxy by setting http_proxy to "http://127.0.0.1:8118"
3. point konqueror to http://p.p (whortcut to privoxys config page)
4. get a "host not found" instead of the config page
5. point firefox at http://p.p and get the correct config page
Actual Results:  
see steps 4&5

Expected Results:  
see steps 4&5

bug happens in KDE 4.9.0 release
Comment 1 Mathias Homann 2012-11-25 10:57:22 UTC
openSUSE uses the standard proxy variables, http_proxy and https_proxy, but kde control center "Automatically detects" the following as ONE variable name:

"HTTP_PROXY,http_proxy,HTTPPROXY,httpproxy,PROXY,proxy" (minus the quotes).

Of course THAT can NOT work. This bug has been around since KDE 4.8...
Comment 2 Marian Kyral 2013-05-20 10:41:31 UTC
Created attachment 79971 [details]
Proxy configuration

I can confirm it. See the attached image.

Gentoo, KDE 4.10.3
Comment 3 Andrea Iacovitti 2013-10-06 12:45:30 UTC
https://git.reviewboard.kde.org/r/113129/
Comment 4 Andrea Iacovitti 2013-10-06 13:25:46 UTC
Git commit 623adc32ca7f4c151a00b7de078bff2aa527201a by Andrea Iacovitti.
Committed on 06/10/2013 at 13:12.
Pushed by aiacovitti into branch 'KDE/4.11'.

Use the correct variable, instead of the entire QStringList, to fill in
lineedit's text in autoDetectSystemProxy().
When saving for "System Proxy" configuration be sure to write the name
of environment variables and not their values in the configuration file.
Added missing signal connection for mUi.systemProxyRadioButton.
Connect slotChanged() to textEdited() signal, instead of textChanged(),
for systemProxy's lineedits: this avoid to emit changed() when
"Show the value of the envirnment variables" checkbox is clicked.
FIXED-IN: 4.11.3
REVIEW: 113129

M  +21   -11   konqueror/settings/kio/kproxydlg.cpp

http://commits.kde.org/kde-baseapps/623adc32ca7f4c151a00b7de078bff2aa527201a