Bug 304312 - Unable to Open New Rekonq Window or Open Links into Rekonq
Summary: Unable to Open New Rekonq Window or Open Links into Rekonq
Status: RESOLVED FIXED
Alias: None
Product: rekonq
Classification: Unclassified
Component: general (show other bugs)
Version: latest git snapshot
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-31 04:50 UTC by David E. Narvaez
Modified: 2012-08-07 02:42 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David E. Narvaez 2012-07-31 04:50:18 UTC
When I use latest master I cannot open new Rekonq windows once the session is restored - e.g., after loging in, I cannot open more rekonq windows than those that were restored. I also cannot open links I have in other applications: I have Rekonq as my default web browser but when I click on a link on Konversation, it is never opened on Rekonq.

Reproducible: Always

Steps to Reproduce:
1. Log out of your session with Rekonq open and session restoration enabled
2. Log back in and wait for all rekonq windows to load
3. Look for Rekonq in  your app launcher or konsole
Actual Results:  
No new Rekonq window opens.

Expected Results:  
A new Rekonq window should be opened.

Andrea, I did a quick inspection of recent commits on file src/application.cpp and found commit 050659a8 to be a suspect. I reverted the commit (needed to fix a conflict on src/bookmarks/bookmarksmanager.cpp) recompiled and reinstalled and the problem was gone.

But of course that reintroduces whatever bug was fixed with the commit (I see two on the commit log) so if you can confirm this bug on your side (or anyone else) maybe we should sit and see what are all possible cases and how to deal with all of them properly.
Comment 1 Andrea Diamantini 2012-07-31 08:00:10 UTC
Git commit cf0a49d107f4890cdd0ce203a891dfab49bd80f4 by Andrea Diamantini.
Committed on 31/07/2012 at 09:59.
Pushed by adjam into branch 'master'.

Correctly handle session restore

The problem here is that the app is considered "session restored" for
all its life cycle. Checking it just when launched without arguments
and with isFirstLoad = true

Should work, im my tests do, needs more testing...

M  +78   -75   src/application.cpp

http://commits.kde.org/rekonq/cf0a49d107f4890cdd0ce203a891dfab49bd80f4
Comment 2 David E. Narvaez 2012-08-07 02:42:50 UTC
Working for me too, thanks. I'm closing it for now, will reopen if during tests something goes wrong again.