Bug 304160 - Adding a page break while cursor is inside a table behaves in a weird way
Summary: Adding a page break while cursor is inside a table behaves in a weird way
Status: RESOLVED FIXED
Alias: None
Product: calligrawords
Classification: Unclassified
Component: tables (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Calligra Words Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-27 21:57 UTC by Lasse Liehu
Modified: 2012-07-29 20:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lasse Liehu 2012-07-27 21:57:45 UTC
I tried to add a page break while the text cursor was inside a table cell and something I didn't expect happened.

Reproducible: Always

Steps to Reproduce:
1.Create a new document
2.Add a table and keep the text cursor inside a cell
3.Try to add a page break using Text editing | Insert | Insert a page break
Actual Results:  
It looks like a newline was just made inside the table cell.

Expected Results:  
Not sure, probably nothing happening.
Comment 1 Gopalakrishna Bhat 2012-07-29 20:13:49 UTC
Git commit 35496bb5bd7a9f3cc5065e6a893982f76adbf379 by Gopalakrishna Bhat A.
Committed on 29/07/2012 at 22:12.
Pushed by gopalakrishnabhat into branch 'master'.

Fix bug 304160: Do not allow insert page break inside tables

M  +5    -0    libs/kotext/KoTextEditor.cpp

http://commits.kde.org/calligra/35496bb5bd7a9f3cc5065e6a893982f76adbf379