Bug 302163 - Crash when press "Minimize Crossing Edges"
Summary: Crash when press "Minimize Crossing Edges"
Status: RESOLVED WORKSFORME
Alias: None
Product: Rocs
Classification: Unclassified
Component: general (show other bugs)
Version: 1.6
Platform: Archlinux Packages Linux
: NOR crash with 10 votes (vote)
Target Milestone: ---
Assignee: Andreas Cord-Landwehr
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-19 03:53 UTC by Diogo Leal
Modified: 2018-11-29 09:40 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Kcrash file (1.13 KB, application/octet-stream)
2012-06-19 03:53 UTC, Diogo Leal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diogo Leal 2012-06-19 03:53:40 UTC
Created attachment 71931 [details]
Kcrash file

1 - click Tools > Generate Graph 
2 - Drag some "balls" 
3 - Click several times in "Minimize Crossing Edges"
Comment 1 Andreas Cord-Landwehr 2012-06-19 13:17:54 UTC
Could be a threading issue, but hard to say from the crash report. For the next time, could you install the boost graph library debug symbols?
To the reported crash: did you press the  "minimize crossing edges" at a high frequence when the crash happend?
And further: how many nodes (roughly) and pointers (also roughly) were selected for the transformation?
Comment 2 Diogo Leal 2012-06-20 12:35:01 UTC
(In reply to comment #1)
> Could be a threading issue, but hard to say from the crash report. For the
> next time, could you install the boost graph library debug symbols?

Ah! Thanks for your tips. 

> To the reported crash: did you press the  "minimize crossing edges" at a
> high frequence when the crash happend?
Don't have a number set

> And further: how many nodes (roughly) and pointers (also roughly) were
> selected for the transformation?
Any pointers
Comment 3 Patrick Eigensatz 2012-11-05 17:40:44 UTC
Can confirm this too. (rocs in KDE 4.8.4)
Could not generate a backtrace, missing libs.
Comment 4 Andreas Cord-Landwehr 2012-12-03 20:37:17 UTC
Git commit 0ec062a811c4d5a0ad43ac3f7d091dae217624bb by Andreas Cord-Landwehr.
Committed on 03/12/2012 at 21:32.
Pushed by cordlandwehr into branch 'master'.

Add workaround for crash with Min-Crossing-Edges.

The crash is probably within the Boost implementation of the
Fruchterman Reingold algorithm.

M  +10   -1    RocsCore/Modifiers/Topology.cpp

http://commits.kde.org/rocs/0ec062a811c4d5a0ad43ac3f7d091dae217624bb
Comment 5 Andrew Crouthamel 2018-10-29 22:41:17 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 6 Bug Janitor Service 2018-11-13 14:38:49 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 7 Bug Janitor Service 2018-11-29 09:40:35 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!