Bug 301666 - a connected link to e.g. openvpn cannot more disconnected
Summary: a connected link to e.g. openvpn cannot more disconnected
Status: RESOLVED WAITINGFORINFO
Alias: None
Product: Network Management
Classification: Unclassified
Component: Plasma Widget (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-11 16:51 UTC by Sven Assmann
Modified: 2012-07-09 00:25 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
see the missing disconnect button (152.46 KB, image/png)
2012-06-11 16:52 UTC, Sven Assmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Assmann 2012-06-11 16:51:19 UTC
a connected link to e.g. openvpn cannot more disconnected because the previous known red x-button to disconnect is not more there. Also right click not offers a posibility to disconnect. So a startet connection can never be disconnected. (see attachment)

This seems only to occur in the latest neon project packages. The previos latest stable does contain the red x-button to disconnect and work also as expected.

Reproducible: Always

Steps to Reproduce:
1.connect to e.g. vpn 
2.try to disconnect
3.the button to do so is missing
Comment 1 Sven Assmann 2012-06-11 16:52:14 UTC
Created attachment 71742 [details]
see the missing disconnect button

please find the red x disconnect button... it seems to be gone
Comment 2 Lamarque V. Souza 2012-06-12 16:52:28 UTC
Git commit 2a9f66ea262e0c020a1edb00c2ed430ba933eb03 by Lamarque V. Souza.
Committed on 12/06/2012 at 18:42.
Pushed by lvsouza into branch 'master'.

Fix connection list if the plasmoid is launched before the kded module.
Related: bug 301478

M  +15   -13   applet/networkmanager.cpp
M  +6    -0    libs/client/remoteactivatablelist.cpp

http://commits.kde.org/networkmanagement/2a9f66ea262e0c020a1edb00c2ed430ba933eb03
Comment 3 Lamarque V. Souza 2012-06-12 19:07:24 UTC
Git commit bbb8431d5664e64b5816052ab2a60a5fcfdd0901 by Lamarque V. Souza.
Committed on 12/06/2012 at 18:42.
Pushed by lvsouza into branch 'nm09'.

Fix connection list if the plasmoid is launched before the kded module.
Related: bug 301478

M  +16   -13   applet/networkmanager.cpp
M  +6    -0    libs/client/remoteactivatablelist.cpp
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/bbb8431d5664e64b5816052ab2a60a5fcfdd0901
Comment 4 Lamarque V. Souza 2012-06-22 00:20:32 UTC
Can you check if Plasma NM 0.9.0.3 fixes this problem for you?