Bug 301590 - Using find/search resizes small windows in Kile
Summary: Using find/search resizes small windows in Kile
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: part (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 300950 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-10 16:59 UTC by adam.larios
Modified: 2012-11-11 19:44 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description adam.larios 2012-06-10 16:59:10 UTC
When the Kile window is smaller than needed for the "find" menu, the window resizes itself to fit the new menu as soon as focus is lost on the window.  This is a problem because if the user has set the window size to something they like, everytime they use "find", they will have to reset their window size.  For example:

I use half of my screen (resolution: 1366x768) for the editor, and the other half to view the output (usually a dvi or pdf).  Every time I hit "CRTL+f" and then click on the output, which happens every few minutes, my editor window resizes and overlaps with the output part.  This is exremely annoying.

An easy partial fix might be to just shrink "find" menu's minimum requred space.  Currently, part of the menu is just blank, and is not necessary.

Reproducible: Always

Steps to Reproduce:
1. Open an editor window in Kile, and shrink it to be horizontally small (e.g. a few cm).
2. Hit CTRL+F
3. Click outside of Kile on another window (such as a pdf)
Actual Results:  
The window will now be resized to fit the "find" menu."  It also cannot be resized to be small again until the "find" menu is closed.

Expected Results:  
The window should not resize, and should remain with the size it was given in the first place.  The "find" menu should stay collapsed, as it is when you first hit "CTRL+F"

This has happened with several versions of KDE (and KDE running under Gnome and Unity).
Comment 1 Michel Ludwig 2012-06-12 18:57:54 UTC
*** Bug 301036 has been marked as a duplicate of this bug. ***
Comment 2 Michel Ludwig 2012-06-12 19:02:11 UTC
*** Bug 300950 has been marked as a duplicate of this bug. ***
Comment 3 Michel Ludwig 2012-06-17 19:33:02 UTC
Forwarding to KatePart.

The layout constraints of the search pane could maybe be changed in such a way that they don't enforce a change of the window size.
Comment 4 Till Schäfer 2012-09-12 11:08:02 UTC
i can confirm the beahviour. this is very anoying when unsing kile side by side with a pdf viewer. everytime i am searching or replacing (which is quite often) i have to resize kile again to not overlap the pdf viewer.
Comment 5 Christoph Cullmann 2012-11-11 19:44:42 UTC
Git commit 8eab44af53013d2293b8028fcbce41bc482d9d31 by Christoph Cullmann.
Committed on 11/11/2012 at 20:38.
Pushed by cullmann into branch 'master'.

change size constraints
no jumping windows anymore

M  +2    -0    part/search/katesearchbar.cpp
M  +2    -2    part/search/searchbarincremental.ui
M  +2    -2    part/search/searchbarpower.ui

http://commits.kde.org/kate/8eab44af53013d2293b8028fcbce41bc482d9d31