Bug 301568 - click till segfault Kjumpingcube
Summary: click till segfault Kjumpingcube
Status: RESOLVED FIXED
Alias: None
Product: kjumpingcube
Classification: Unclassified
Component: general (show other bugs)
Version: 1.2
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Ian Wadham
URL:
Keywords:
: 327800 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-10 11:34 UTC by Andreas Kölbl
Modified: 2013-11-19 13:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 1.2 (KDE SC 4.9)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Kölbl 2012-06-10 11:34:18 UTC
Application: kjumpingcube (1.2)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Fast clicking until the end. Shortly before you win you are able to click fast in the cubes which are on your way to win. Then should the application crash.

-- Backtrace:
Application: KJumpingCube (kjumpingcube), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  0x000000000040fa96 in checkComputerplayer (player=CubeBoxBase<KCubeWidget>::Two, this=0x21391a0) at ../../kjumpingcube/kcubeboxwidget.cpp:399
#7  KCubeBoxWidget::checkComputerplayer (this=0x21391a0, player=CubeBoxBase<KCubeWidget>::Two) at ../../kjumpingcube/kcubeboxwidget.cpp:376
#8  0x000000000040fb04 in KCubeBoxWidget::changePlayer (this=0x21391a0) at ../../kjumpingcube/kcubeboxwidget.cpp:796
#9  0x000000000040fdc7 in KCubeBoxWidget::checkClick (this=0x21391a0, row=6, column=5, isClick=<optimized out>) at ../../kjumpingcube/kcubeboxwidget.cpp:369
#10 0x0000000000412018 in qt_static_metacall (_a=0x7fff74924cc0, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./kcubeboxwidget.moc:88
#11 KCubeBoxWidget::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7fff74924cc0) at ./kcubeboxwidget.moc:68
#12 0x00007fe3bc56c281 in QMetaObject::activate (sender=0x21c4f80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff74924cc0) at kernel/qobject.cpp:3547
#13 0x0000000000414fe8 in KCubeWidget::clicked (this=<optimized out>, _t1=6, _t2=5, _t3=true) at ./kcubewidget.moc:110
#14 0x00007fe3bb92b144 in QWidget::event (this=0x21c4f80, event=0x7fff74925550) at kernel/qwidget.cpp:8362
#15 0x00007fe3bbceb3b6 in QFrame::event (this=0x21c4f80, e=0x7fff74925550) at widgets/qframe.cpp:557
#16 0x00007fe3bb8da894 in notify_helper (e=0x7fff74925550, receiver=0x21c4f80, this=0x1f89cb0) at kernel/qapplication.cpp:4559
#17 QApplicationPrivate::notify_helper (this=0x1f89cb0, receiver=0x21c4f80, e=0x7fff74925550) at kernel/qapplication.cpp:4531
#18 0x00007fe3bb8e00bf in QApplication::notify (this=<optimized out>, receiver=0x21c4f80, e=0x7fff74925550) at kernel/qapplication.cpp:4102
#19 0x00007fe3bd210bb6 in KApplication::notify (this=0x7fff749275e0, receiver=0x21c4f80, event=0x7fff74925550) at ../../kdeui/kernel/kapplication.cpp:311
#20 0x00007fe3bc557e9c in QCoreApplication::notifyInternal (this=0x7fff749275e0, receiver=0x21c4f80, event=0x7fff74925550) at kernel/qcoreapplication.cpp:876
#21 0x00007fe3bb8db862 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#22 QApplicationPrivate::sendMouseEvent (receiver=0x21c4f80, event=0x7fff74925550, alienWidget=0x21c4f80, nativeWidget=0x21391a0, buttonDown=0x21c4f80, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3170
#23 0x00007fe3bb95abf5 in QETWidget::translateMouseEvent (this=0x21391a0, event=<optimized out>) at kernel/qapplication_x11.cpp:4617
#24 0x00007fe3bb959bae in QApplication::x11ProcessEvent (this=0x7fff749275e0, event=0x7fff74925e20) at kernel/qapplication_x11.cpp:3732
#25 0x00007fe3bb9830d2 in x11EventSourceDispatch (s=0x1f7c3a0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#26 0x00007fe3b7293c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007fe3b7294060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fe3b7294124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fe3bc5873bf in QEventDispatcherGlib::processEvents (this=0x1f5bbe0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#30 0x00007fe3bb982d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007fe3bc556c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007fe3bc556ed7 in QEventLoop::exec (this=0x7fff749261c0, flags=...) at kernel/qeventloop.cpp:204
#33 0x00007fe3bbdaa936 in QDialog::exec (this=0x21dc4d0) at dialogs/qdialog.cpp:554
#34 0x00007fe3bd1776fa in KMessageBox::createKMessageBox (dialog=<optimized out>, icon=..., text=..., strlist=..., ask=..., checkboxReturn=0x7fff7492687f, options=..., details=..., notifyType=QMessageBox::Information) at ../../kdeui/dialogs/kmessagebox.cpp:344
#35 0x00007fe3bd177ed4 in KMessageBox::createKMessageBox (dialog=0x21dc4d0, icon=QMessageBox::Information, text=..., strlist=..., ask=..., checkboxReturn=0x7fff7492687f, options=..., details=...) at ../../kdeui/dialogs/kmessagebox.cpp:159
#36 0x00007fe3bd17b31f in informationListWId (options=..., dontShowAgainName=..., caption=..., strlist=..., text=..., parent_id=88080403) at ../../kdeui/dialogs/kmessagebox.cpp:1005
#37 KMessageBox::informationListWId (parent_id=88080403, text=..., strlist=..., caption=..., dontShowAgainName=..., options=...) at ../../kdeui/dialogs/kmessagebox.cpp:979
#38 0x00007fe3bd17b48f in KMessageBox::informationList (parent=<optimized out>, text=..., strlist=..., caption=..., dontShowAgainName=..., options=...) at ../../kdeui/dialogs/kmessagebox.cpp:976
#39 0x00007fe3bd17b4e8 in KMessageBox::information (parent=<optimized out>, text=..., caption=..., dontShowAgainName=..., options=...) at ../../kdeui/dialogs/kmessagebox.cpp:963
#40 0x000000000040c230 in KJumpingCube::showWinner (this=0x213d1a0, player=1) at ../../kjumpingcube/kjumpingcube.cpp:263
#41 0x00007fe3bc56c281 in QMetaObject::activate (sender=0x21391a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff74926b20) at kernel/qobject.cpp:3547
#42 0x000000000040f8bf in KCubeBoxWidget::playerWon (this=<optimized out>, _t1=1) at ./kcubeboxwidget.moc:155
#43 0x000000000040fceb in KCubeBoxWidget::nextLoopStep (this=0x21391a0) at ../../kjumpingcube/kcubeboxwidget.cpp:772
#44 0x00007fe3bc56c281 in QMetaObject::activate (sender=0x21de900, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#45 0x00007fe3bc571179 in QObject::event (this=0x21de900, e=<optimized out>) at kernel/qobject.cpp:1157
#46 0x00007fe3bb8da894 in notify_helper (e=0x7fff74927300, receiver=0x21de900, this=0x1f89cb0) at kernel/qapplication.cpp:4559
#47 QApplicationPrivate::notify_helper (this=0x1f89cb0, receiver=0x21de900, e=0x7fff74927300) at kernel/qapplication.cpp:4531
#48 0x00007fe3bb8df713 in QApplication::notify (this=0x7fff749275e0, receiver=0x21de900, e=0x7fff74927300) at kernel/qapplication.cpp:4420
#49 0x00007fe3bd210bb6 in KApplication::notify (this=0x7fff749275e0, receiver=0x21de900, event=0x7fff74927300) at ../../kdeui/kernel/kapplication.cpp:311
#50 0x00007fe3bc557e9c in QCoreApplication::notifyInternal (this=0x7fff749275e0, receiver=0x21de900, event=0x7fff74927300) at kernel/qcoreapplication.cpp:876
#51 0x00007fe3bc5891f2 in sendEvent (event=0x7fff74927300, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#52 QTimerInfoList::activateTimers (this=0x1f8d560) at kernel/qeventdispatcher_unix.cpp:611
#53 0x00007fe3bc586c0d in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#54 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#55 0x00007fe3bc586c31 in idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:233
#56 0x00007fe3b7293c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#57 0x00007fe3b7294060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#58 0x00007fe3b7294124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#59 0x00007fe3bc5873bf in QEventDispatcherGlib::processEvents (this=0x1f5bbe0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#60 0x00007fe3bb982d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#61 0x00007fe3bc556c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#62 0x00007fe3bc556ed7 in QEventLoop::exec (this=0x7fff74927570, flags=...) at kernel/qeventloop.cpp:204
#63 0x00007fe3bc55bf67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#64 0x000000000040a33f in main (argc=3, argv=0x7fff749278d8) at ../../kjumpingcube/main.cpp:60

Reported using DrKonqi
Comment 1 Ian Wadham 2012-06-24 02:39:40 UTC
SVN commit 1302625 by ianw:

Related: bug 269781 BUG: bug 301568 BUG: bug 302151 Fix several crashes by making sure all game activity stops before accepting close().
Comment 2 Jekyll Wu 2013-11-19 13:16:57 UTC
*** Bug 327800 has been marked as a duplicate of this bug. ***