Bug 301478 - Unable to recognize existing vpn connection on logging in.
Summary: Unable to recognize existing vpn connection on logging in.
Status: RESOLVED FIXED
Alias: None
Product: Network Management
Classification: Unclassified
Component: Plasma Widget (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-09 00:34 UTC by Yichao Yu
Modified: 2012-07-17 17:19 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.9.0.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yichao Yu 2012-06-09 00:34:06 UTC
When logging in with a connected vpn connection. The plasma widget cannot recognize it. 'Managing connection' is fine and restarting plasma-desktop can "fix" it.


Reproducible: Always

Steps to Reproduce:
1. make a vpn connection (probably system connection or any vpn connection that can maintain after logging out.)
2. log out
3. log in

Actual Results:  
the plasma widget shows not connected (though it is connected)

Expected Results:  
~~ should say it is connected ~~

There will be some really weird behavior if I try to "reconnect" the existing connection.
Comment 1 Lamarque V. Souza 2012-06-12 15:11:42 UTC
Which Plasma NM version do you use? You can see the version in "Manage Connections" -> "Other".
Comment 2 Lamarque V. Souza 2012-06-12 16:52:28 UTC
Git commit 2a9f66ea262e0c020a1edb00c2ed430ba933eb03 by Lamarque V. Souza.
Committed on 12/06/2012 at 18:42.
Pushed by lvsouza into branch 'master'.

Fix connection list if the plasmoid is launched before the kded module.
Related: bug 301666

M  +15   -13   applet/networkmanager.cpp
M  +6    -0    libs/client/remoteactivatablelist.cpp

http://commits.kde.org/networkmanagement/2a9f66ea262e0c020a1edb00c2ed430ba933eb03
Comment 3 Yichao Yu 2012-06-12 18:08:12 UTC
~ Just in case u still need my version. It's 0.9.0.2 (nm09 20120507) from the 4.8.80 package of archlinux.
Comment 4 Lamarque V. Souza 2012-06-12 19:07:24 UTC
Git commit bbb8431d5664e64b5816052ab2a60a5fcfdd0901 by Lamarque V. Souza.
Committed on 12/06/2012 at 18:42.
Pushed by lvsouza into branch 'nm09'.

Fix connection list if the plasmoid is launched before the kded module.
Related: bug 301666

M  +16   -13   applet/networkmanager.cpp
M  +6    -0    libs/client/remoteactivatablelist.cpp
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/bbb8431d5664e64b5816052ab2a60a5fcfdd0901
Comment 5 Lamarque V. Souza 2012-06-22 00:20:19 UTC
Can you check if Plasma NM 0.9.0.3 fixes this problem for you?
Comment 6 Yichao Yu 2012-06-22 07:24:25 UTC
Sorry I am not able to use 0.9.0.3 due to a problem on [openconnect support](https://bugs.archlinux.org/task/30398)
(plasma-nm 0.9.0.3 with my current version of nm support neither openconnect 1:3.18 or 1:4.00)
Comment 7 Lamarque V. Souza 2012-07-17 17:13:22 UTC
Well, I have teste it here and the problem seems fixed. Reopen the bug if it happens again.
Comment 8 Yichao Yu 2012-07-17 17:19:06 UTC
THX, will test when new networkmanager release is available.

(In reply to comment #7)
> Well, I have teste it here and the problem seems fixed. Reopen the bug if it
> happens again.