Bug 301287 - Watch windows displays "error" after changing he file/run
Summary: Watch windows displays "error" after changing he file/run
Status: RESOLVED FIXED
Alias: None
Product: kdevelop
Classification: Unclassified
Component: CPP Debugger (show other bugs)
Version: git master
Platform: Fedora RPMs Linux
: NOR major with 1 vote (vote)
Target Milestone: 4.4.0
Assignee: David E. Narvaez
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-06 15:25 UTC by leon pollak
Modified: 2012-09-02 18:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description leon pollak 2012-06-06 15:25:58 UTC
Assume I run the debugger and add some variables to watch. Then I stop the debugger, modify some changes and run the debugger again. This time, the variables are in "italic" format and the values of all the variables are set to "Error".
So I have to delete all of the watched variable and add them again.

Reproducible: Always

Steps to Reproduce:
See above.
Actual Results:  
Error in display

Expected Results:  
Watched variable presented
Comment 1 David E. Narvaez 2012-09-01 04:30:19 UTC
Git commit cc8c9466675fcd022f45f81be97872a8527bb8d9 by David E. Narváez.
Committed on 01/09/2012 at 06:26.
Pushed by narvaez into branch '4.4'.

Add Thread and Frame Information on Execution

Moved the code that adds frame and thread information when not present
in the command already from the queueCmd method to the executeCmd
method and added some info at the debug strings to make clear that the
queued command will be modified upon execution. This is needed in order
to be able to queue commands whose information depend on previous
commands in the same queue.
REVIEW: 105210

M  +24   -9    debuggers/gdb/debugsession.cpp
M  +32   -3    debuggers/gdb/unittests/gdbtest.cpp
M  +1    -0    debuggers/gdb/unittests/gdbtest.h

http://commits.kde.org/kdevelop/cc8c9466675fcd022f45f81be97872a8527bb8d9
Comment 2 Niko Sams 2012-09-02 18:40:40 UTC
Git commit 36b72ce6b3c1eaaf1485c9eacbcdd3171d03f01f by Niko Sams.
Committed on 02/09/2012 at 20:36.
Pushed by nsams into branch '4.4'.

unitest for bug that was fixed in kdevplatform (rev 5fdbb0d1bf5febaf7497f0ea947ff82fc7c6baaf)

M  +41   -0    debuggers/gdb/unittests/gdbtest.cpp
M  +1    -0    debuggers/gdb/unittests/gdbtest.h

http://commits.kde.org/kdevelop/36b72ce6b3c1eaaf1485c9eacbcdd3171d03f01f
Comment 3 Niko Sams 2012-09-02 18:40:45 UTC
Git commit 5fdbb0d1bf5febaf7497f0ea947ff82fc7c6baaf by Niko Sams.
Committed on 02/09/2012 at 20:34.
Pushed by nsams into branch '1.4'.

when entering paused state set current frame to none

- fixes flicker when current frame was set to another one because this one didn't have debug information
- fixes timing issues with watches where currentFrameChanged triggered an update before frames and threads are updated

Unittest for this issue is in gdb plugin

M  +1    -1    debugger/framestack/framestackmodel.cpp

http://commits.kde.org/kdevplatform/5fdbb0d1bf5febaf7497f0ea947ff82fc7c6baaf