Bug 299658 - Set the focus to password textbox in User Bar theme.
Summary: Set the focus to password textbox in User Bar theme.
Status: RESOLVED FIXED
Alias: None
Product: lightdm
Classification: Unclassified
Component: greeter (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR wishlist
Target Milestone: 0.2.2
Assignee: David Edmundson
URL:
Keywords:
: 300383 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-08 21:50 UTC by Rafael
Modified: 2012-08-19 14:10 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael 2012-05-08 21:50:41 UTC
Please, set the keyboard focus to password input textbox when the user name (or face) is selected in the User Bar theme.

Reproducible: Always

Steps to Reproduce:
1. Use the User Bar theme.
2. Click on a user name/face.
3. Try to type now the password.
4. You will see that the password is not written.
5. Now you need to click on the password textbox and re-type the password.
Actual Results:  
4. You will see that the password is not written.
5. Now you need to click on the password textbox and re-type the password.

Expected Results:  
When a user is selected, the password textbox should be ready to grab the keyboard. And clicking again in password textbox to enter the password should not be necessary.
Comment 1 David Edmundson 2012-07-30 07:52:18 UTC
I don't want to just assign focus to the password box. If you're logging in you need to have focus to select the user first, otherwise you'd have to unselect from the password box to something that logically comes first.

However the problem you have is still valid, so what I've done is the following:
 - focus is on the user selection
 - if you press a key that is not "left" or "right" cursors it puts focus on the password box, and copies across the letter you pressed

What this means is if you're already selected the correct user you can just start typing. Or you can press left/right and then just start typing a password. Pressing enter straight away will focus the password box. Typing and then pressing enter will start a login.

(needs to go through review, will then merge)
Comment 2 David Edmundson 2012-07-31 20:50:31 UTC
*** Bug 300383 has been marked as a duplicate of this bug. ***
Comment 3 David Edmundson 2012-08-19 14:10:11 UTC
> Git commit 87c84950216d779af139c15b051a6e8cd24bee93 by David Edmundson.
> Committed on 30/07/2012 at 12:05.
> Pushed by davidedmundson into branch 'master'.
>
> Improve keyboard handling in Userbar theme
>
> When pressing any character whilst the user selection has focus, this character will be passed to the password input
> When pressing escape in the password input, focus is returned to the user selection
>
> REVIEW: 105789
>
> M  +24   -0    themes/userbar/main.qml
>
> http://commits.kde.org/lightdm/87c84950216d779af139c15b051a6e8cd24bee93