Bug 299332 - Application Icon for Rocs
Summary: Application Icon for Rocs
Status: RESOLVED FIXED
Alias: None
Product: Oxygen
Classification: Unclassified
Component: icons (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: pinheiro
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-03 21:27 UTC by Andreas Cord-Landwehr
Modified: 2013-08-03 14:05 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Idea sketch for application icon. (2.55 KB, image/png)
2013-03-29 09:53 UTC, Andreas Cord-Landwehr
Details
A color sketch (67.44 KB, image/png)
2013-08-02 09:18 UTC, Yuri Chornoivan
Details
A new version (16.52 KB, image/svg+xml)
2013-08-02 20:18 UTC, Yuri Chornoivan
Details
hide cutting of wheel (69.32 KB, image/png)
2013-08-03 07:55 UTC, Andreas Cord-Landwehr
Details
Revised version of the sketch (17.57 KB, image/svg+xml)
2013-08-03 11:33 UTC, Yuri Chornoivan
Details
Update (18.63 KB, application/octet-stream)
2013-08-03 11:56 UTC, Andreas Cord-Landwehr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Cord-Landwehr 2012-05-03 21:27:17 UTC
Rocs (part of KDE-Edu) is missing an application icon.
Rocs itself is an advanced graph simulator program that helps simulating, testing and understanding data structure algorithms. (http://edu.kde.org/applications/all/rocs/).
In summary: users can use graphical interface to create an arbitrary graph (this can also be a specific data structure like a linked list or a rooted tree), connect the nodes with edges, write an algorithm and visually see how the algorithm changes the graph.

Reproducible: Always

Actual Results:  
We do not have an icon.

Expected Results:  
An application icon would be awesome :)

If you need any additional information, please contact me directly or use the rocs-devel@kde.org list.
Comment 1 Andreas Cord-Landwehr 2013-03-29 09:53:34 UTC
Created attachment 78473 [details]
Idea sketch for application icon.

This is a rough idea sketch for the application icon. The meaning is: Join of the simulation part (indicated by the gear) and the data structure part (indicated by the graph structure at the right). But to make it looking really awesome and fit into the Oxygen icon scheme, our skills do not suffice...

Greetings, Andreas
Comment 2 Yuri Chornoivan 2013-08-02 09:18:10 UTC
Created attachment 81525 [details]
A color sketch

Can it be like this?
Comment 3 Yuri Chornoivan 2013-08-02 20:18:36 UTC
Created attachment 81537 [details]
A new version

Honestly, cannot figure out what is the "fusion" and how it can be applied. Sorry.
Comment 4 Andreas Cord-Landwehr 2013-08-03 07:54:28 UTC
Looking really nice! Only some small points (tried some by myself in attachment, makes it easier than describing everything in text):
* the point where graph and wheel are combined looks like it is simply cut and pasted, maybe add some further graph edges to hide this (see attachment)
* what do you think about using the same with for the graph edges as for the innermost list of the wheel?
* the wheel shadow where the wheel is cut look "cutted" :) can that be fixed with fading out? (that goes far beyond my Inkscape skills ;)
* I think the green nodes must be mirrored vertically and horizontally to get the light effects right
Thanks a lot!
Comment 5 Andreas Cord-Landwehr 2013-08-03 07:55:17 UTC
Created attachment 81540 [details]
hide cutting of wheel
Comment 6 Yuri Chornoivan 2013-08-03 11:33:51 UTC
Created attachment 81541 [details]
Revised version of the sketch

Fixed some issues (I hope).
The green nodes are identical to the blue ones so nothing was changed.
Comment 7 Andreas Cord-Landwehr 2013-08-03 11:56:56 UTC
Created attachment 81542 [details]
Update

2 minor things
* I would add nodes such that every chrossing of graph edges have a node
* and I have the feeling that it looks nicer to have the graph edge not wrapping around at the wheel
What's the next step then? Ask Nuno what he thinks? Or can it go directly into Rocs?
Comment 8 Andreas Cord-Landwehr 2013-08-03 14:05:14 UTC
Git commit 70c0c646653dde11530bcf12b39711c8522ec02f by Andreas Cord-Landwehr.
Committed on 03/08/2013 at 13:31.
Pushed by cordlandwehr into branch 'KDE/4.11'.

Set new Rocs application icon.

Thanks to Yuri for creating it!

M  +1    -1    App/CMakeLists.txt
D  +-    --    graphics/global/hi16-app-rocs.png
A  +-    --    graphics/global/hi16-apps-rocs.png
D  +-    --    graphics/global/hi32-app-rocs.png
A  +-    --    graphics/global/hi32-apps-rocs.png
D  +-    --    graphics/global/hi48-app-rocs.png
A  +-    --    graphics/global/hi48-apps-rocs.png
A  +-    --    graphics/global/hi64-apps-rocs.png
A  +-    --    graphics/global/hisc-apps-rocs.svgz
D  +0    -5758 graphics/icon.svg

http://commits.kde.org/rocs/70c0c646653dde11530bcf12b39711c8522ec02f