Bug 297989 - If unsaved document has a "Name", automatically fill it in as the filename in save dialog.
Summary: If unsaved document has a "Name", automatically fill it in as the filename in...
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: git master (please specify the git hash!)
Platform: Compiled Sources Linux
: NOR wishlist
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords: junior-jobs
Depends on:
Blocks:
 
Reported: 2012-04-12 18:19 UTC by Tom Hall
Modified: 2018-02-23 15:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Hall 2012-04-12 18:19:17 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Build Identifier: 

If the document has a name specified (i.e. not "unnamed"), automatically fill this name in as the filename when saving for the first time.

This wish assumes that the user likes to save a document named, "Piggy Wiggies" as something similar, e.g. "Piggy Wiggies.kra". 


Reproducible: Always

Steps to Reproduce:
1. Create a new document. Make sure to fill in the "Name" field with something other than the default, "unnamed".
2. Open the save dialog via menu > Save As.
Actual Results:  
Name field is empty.

Expected Results:  
Name field contains the document name (as a starting point for the filename).

Might have to truncate the document name if it is allowed more characters than filenames are (I don't know if this is the case).

Shouldn't take precedence over filename in subsequent saves, only applies for 1st save when there is no filename yet.
Comment 1 Halla Rempt 2012-12-29 10:20:45 UTC
Git commit 98f566eba0f724054cf991829afd1b32a50e819f by Boudewijn Rempt.
Committed on 29/12/2012 at 11:21.
Pushed by rempt into branch 'master'.

Use the document name for the filename when creating a named document

M  +4    -0    krita/ui/kis_doc2.cc

http://commits.kde.org/calligra/98f566eba0f724054cf991829afd1b32a50e819f
Comment 2 Halla Rempt 2018-02-23 15:49:22 UTC
Git commit b254dbad8019427b22b357284ef5b33c9698a4d5 by Boudewijn Rempt.
Committed on 23/02/2018 at 15:49.
Pushed by rempt into branch 'master'.

Do not set the url of the document based on the name

This leads to strange bugs because the url is set to
Pictures/name, but the document hasn't been saved yet.
Related: bug 390853

M  +1    -4    libs/ui/KisDocument.cpp

https://commits.kde.org/krita/b254dbad8019427b22b357284ef5b33c9698a4d5