Bug 296970 - split view wrong behavior with search tab
Summary: split view wrong behavior with search tab
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: search (show other bugs)
Version: 2.0
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: reproducible
: 324824 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-28 15:15 UTC by vassari
Modified: 2013-09-12 10:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vassari 2012-03-28 15:15:17 UTC
Reproduce bug 1:

- open dolphin
- choose split view in dolphin. So you have the right view R, and the left view L
- choose a folder in R different from the one in L
- click on R, and press Ctrl+f. The find tab apperas above R only (I have Nepomuk off by the way).
- click on L
- click on the find tab above R (while L is selected) and write something

What happends:
folder in L switchs to the folder in R, search start in both views and an empty tab with the close button (may be a find tab) appears above L

Should happend:
search should start in R only
Comment 1 Jeroen van Meeuwen (Kolab Systems) 2012-08-24 16:18:39 UTC
Resetting assignee to default as per bug #305719
Comment 2 Emmanuel Pescosta 2013-09-05 14:25:28 UTC
Git commit 576481d114bdd0b7d1b4039612c7993f4cbb9b84 by Emmanuel Pescosta.
Committed on 05/09/2013 at 14:22.
Pushed by emmanuelp into branch 'KDE/4.11'.

Fix Bug 296970 - split view wrong behavior with search tab

Implemented setActive(bool active), isActive() and activated() signal
for DolphinSearchBox - similar to the KUrlNavigator implementation.
FIXED-IN: 4.11.2
REVIEW: 112534

M  +2    -0    dolphin/src/dolphinviewcontainer.cpp
M  +35   -0    dolphin/src/search/dolphinsearchbox.cpp
M  +25   -0    dolphin/src/search/dolphinsearchbox.h

http://commits.kde.org/kde-baseapps/576481d114bdd0b7d1b4039612c7993f4cbb9b84
Comment 3 Emmanuel Pescosta 2013-09-12 10:56:10 UTC
*** Bug 324824 has been marked as a duplicate of this bug. ***