Bug 292503 - Lancelot can only be closed by pressing ESC
Summary: Lancelot can only be closed by pressing ESC
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-lancelot (show other bugs)
Version: 4.9.0
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Ivan Čukić
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-26 19:43 UTC by Janek Bevendorff
Modified: 2012-08-04 08:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janek Bevendorff 2012-01-26 19:43:01 UTC
Version:           unspecified (using Devel) 
OS:                Linux

I'm using Lancelot as my application launcher and have assigned the keyboard shortcut Super+Space to it. This shortcut brings up the Lancelot plasmoid and until KDE 4.7.4 I was also able to close it again with this shortcut.
However, since KDE 4.8.0 this doesn't work anymore. The only working shortcut for closing Lancelot is ESC.
This is a little annoying, because sometimes I bring up Lancelot, then decide otherwise and close it again. Using the same shortcut for this is much more convenient, as I don't have to move my hand over the whole keyboard.

Reproducible: Always

Steps to Reproduce:
Assign a keyboard shortcut to Lancelot, open it and try to close it again with the same shortcut.

Actual Results:  
Lancelot only closes on ESC key press.

Expected Results:  
I should also be able to close Lancelot with the same keyboard shortcut I used for opening it.
Comment 1 Ivan Čukić 2012-08-03 22:46:41 UTC
Git commit a638450103830cc52dfb25d77a40e4dbbd6b07be by Ivan Čukić.
Committed on 04/08/2012 at 00:42.
Pushed by ivan into branch 'master'.

Lancelot is toggled with the keyboard shortcut

M  +8    -1    applets/lancelot/application/LancelotWindow.cpp
M  +5    -0    applets/lancelot/application/LancelotWindow.h
M  +1    -1    applets/lancelot/launcher/LancelotApplet.cpp

http://commits.kde.org/kdeplasma-addons/a638450103830cc52dfb25d77a40e4dbbd6b07be
Comment 2 Ivan Čukić 2012-08-04 08:23:04 UTC
Git commit 8376fb609af92d09b8983451d4220a2e83dc3d8e by Ivan Čukić.
Committed on 04/08/2012 at 10:15.
Pushed by ivan into branch 'KDE/4.9'.

Backported: Lancelot is toggled with the keyboard shortcut

M  +8    -1    applets/lancelot/application/LancelotWindow.cpp
M  +5    -0    applets/lancelot/application/LancelotWindow.h
M  +1    -1    applets/lancelot/launcher/LancelotApplet.cpp

http://commits.kde.org/kdeplasma-addons/8376fb609af92d09b8983451d4220a2e83dc3d8e