Bug 291389 - move/jump dialog doesn't make a consistent selection and requires extra "arrow down" to select
Summary: move/jump dialog doesn't make a consistent selection and requires extra "arro...
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Unclassified
Component: folders (show other bugs)
Version: 4.7
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-12 19:12 UTC by infrabit
Modified: 2013-06-19 15:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description infrabit 2012-01-12 19:12:17 UTC
Version:           4.7 (using KDE 4.7.3) 
OS:                Linux

typing in the first letters doesn't select the best match requiring an extra key press (arrow down) in order to make the selection

Reproducible: Always

Steps to Reproduce:
Create a folder structure like below:
   t_admin
   t_bugs
   t_cas
   t_library
   t_msp
   \_ t_ecampus
   \_ t_olds
   t_research
   \_ t_elab
   \_ t_sn
   t_zimbra


Note: 'j' or 'm' behave identical so for the purpose of this example I'll refer 
to 'j'.

Scenario 1
==========

1. Press 'j'

2. Type 'inb'

3. Press Enter to jump to 'Inbox' folder

4. Press 'j'

5. Type 't_'

6. Confirm that 't_admin' is selected and press Enter to jump to it

7. Press 'j'

8. Type 't_'

Which folder is selected? In my case it's 't_ecampus' and every time.


Scenario 2
==========

1. Press 'j'

2. Type 'inb'

3. Press Enter to jump to 'Inbox' folder

4. Press 'j'

5. Type 't_'

6. Confirm the selected folder (in my case 't_ecampus')

7. Press Alt-C to cancel

8. Press 'j'

9. Type 't_'

Which folder is now selected? In my case it's 't_olds'. Keep repeating steps 8 
and 9 and notice how the subsequent folder is selected every time.


Scenario 3
==========

1. Press 'j'

2. Type 'inb'

3. Press Enter to jump to 'Inbox' folder

4. Press 'j'

5. Type 't_r'

6. Confirm that 't_research' is selected and press Enter

7. Press 'j'

8. Type 't_a'

9. Confirm that only 't_admin' is shown and it is not selected




Actual Results:  
Scenario 1: folder 't_ecampus' is selected every time

Scenario 2: subsequent folder is selected

Scenario 3: folder 't_admin' must be selected as it's the only match


Expected Results:  
Scenario 1: no folder should be selected as there are several matches

Scenario 2: same as Scenario 1

Scenario 3: 't_admin' must be selected (save user from an extra down arrow 
            which not as close to fingers as letters are).



There are other oddities and if this bug is confirmed I will update as I hit 
them.

Scenarion 3 is the most annoying as it requires the extra down arrow.

It would be nice if the selection dialog will be case sensitive as it will save 
an extra down arrow when selecting between IMAP "Inbox" and POP "inbox".
Comment 1 Laurent Montel 2012-01-12 20:55:20 UTC
"It would be nice if the selection dialog will be case sensitive" no I will not make it as sensitive case because I will not specify write "Inbox" just inbox 

For other problem I will look at it
Comment 2 infrabit 2012-01-12 21:41:32 UTC
(In reply to comment #1)
> "It would be nice if the selection dialog will be case sensitive" no I will not
> make it as sensitive case because I will not specify write "Inbox" just inbox 
> 

What about adding a checkbox under options? For most sysadmins having to grab 
the mouse just to read mail is painful (yes, I use Pentadactyl with Firefox).  
However fixing bug 290596 will make this less important. I can move this under 
a whishlist...
Comment 3 Aurelien Gateau 2013-06-19 15:57:25 UTC
Git commit c89eb9727e47c8dad9981f652500873da085b699 by Aurélien Gâteau.
Committed on 18/06/2013 at 14:59.
Pushed by gateau into branch 'master'.

Fix FolderSelectionDialog not always selecting matching folders

Easiest way to reproduce the bug is to type slowly enough to cause
QTreeView::keyboardSearch() to reset itself.
FIXED-IN: 4.11.0

https://git.reviewboard.kde.org/r/111098/

M  +7    -0    mailcommon/folder/foldertreeview.cpp
M  +2    -0    mailcommon/folder/foldertreeview.h
M  +10   -0    mailcommon/folder/foldertreewidget.cpp

http://commits.kde.org/kdepim/c89eb9727e47c8dad9981f652500873da085b699