Bug 291011 - Clicking on a configuration error in the Build toolview does not bring you to the line in the CMakeLists.txt file
Summary: Clicking on a configuration error in the Build toolview does not bring you to...
Status: RESOLVED FIXED
Alias: None
Product: kdevelop
Classification: Unclassified
Component: Build tools: CMake (show other bugs)
Version: git master
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: 4.2.3
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-09 00:53 UTC by David
Modified: 2013-02-07 18:11 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David 2012-01-09 00:53:33 UTC
Version:           git master (using Devel) 
OS:                Linux

When there is a configure error, the raw text is output in the Build toolview - something like:

CMake Error at Tests/CMakeLists.txt:80 (add_executable)

It would be nice to click this line and have it open the correct CMakeLists.txt file and bring you to the line where the error occurred.


Reproducible: Didn't try

Steps to Reproduce:
Try to build a project with a CMake configure error.

Actual Results:  
Plain text is output - it is not clickable.

Expected Results:  
Clicking on the error should bring you to the file and line where the error occurred.
Comment 1 Aleix Pol 2013-02-07 14:05:05 UTC
This was fixed as of 1c59a4d784f84dd0bc6a32cb13e4136d21e5b9e1.

It will be soon on your system, when we release newer versions...
Comment 2 Morten Danielsen Volden 2013-02-07 17:54:57 UTC
2013/2/7 Aleix Pol <aleixpol@kde.org>

> https://bugs.kde.org/show_bug.cgi?id=291011
>
> Aleix Pol <aleixpol@kde.org> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>              Status|CONFIRMED                   |RESOLVED
>                  CC|                            |aleixpol@kde.org
>          Resolution|---                         |FIXED
>
> --- Comment #1 from Aleix Pol <aleixpol@kde.org> ---
> This was fixed as of 1c59a4d784f84dd0bc6a32cb13e4136d21e5b9e1.
>
> It will be soon on your system, when we release newer versions...
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
>

Ah, yes. When i did the submit of that changelist i got this reply from
bugzilla:

You are not allowed to change the bug status from CONFIRMED to RESOLVED.

I never got round to asking someone if I could get that kind of permission
(Who should I ask BTW?).

The same also applies to:

https://bugs.kde.org/show_bug.cgi?id=291528 (Make "In file included from"
output clickable)

Cheers

Morten
Comment 3 Kevin Funk 2013-02-07 18:11:26 UTC
That's a job for #kde-sysadmin -- just ask I'd say.