Bug 289242 - complex layer name saved in *.ora, not read at opening
Summary: complex layer name saved in *.ora, not read at opening
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: git master (please specify the git hash!)
Platform: Unlisted Binaries Linux
: NOR minor
Target Milestone: ---
Assignee: Halla Rempt
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-18 00:00 UTC by David REVOY
Modified: 2011-12-18 13:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
a ora file funny test : Sad buny if fail / Happy bunny when fixed (137.33 KB, image/openraster)
2011-12-18 00:52 UTC, David REVOY
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David REVOY 2011-12-18 00:00:53 UTC
Version:           svn trunk
OS:                Linux

I had a *.ora scene with a layer named '1885_NZVoorburgwal_(Christiaan_le_Blansch).jpg' ( a texture public domain picture pasted with GIMP, I needed to Iwarp it ) then I reopened in Krita , and the layer didn't load. The ora loaded, but the layer with this name was missing. 
Opening back in Mypaint/Gimp is all ok. 
I suspect Krita skip loading layer name with special characters , witch is not nice :)

The bug is minor, because the simple workaround is to name properly the layer, and I can easily live with this one :) 
 

Reproducible: Always


Actual Results:  
 

Expected Results:
Comment 1 Sven Langkamp 2011-12-18 00:10:45 UTC
Could you attach the file?
Comment 2 David REVOY 2011-12-18 00:52:24 UTC
Created attachment 66844 [details]
a ora file funny test : Sad buny if fail / Happy bunny when fixed
Comment 3 David REVOY 2011-12-18 00:54:27 UTC
Sure, I attached another file , but this file reproduce the mistake ( because I can't post Mango concept art for the moment ). I played to make a little game with it :)
Comment 4 Sven Langkamp 2011-12-18 02:16:03 UTC
I see the problem. Actually the problem is that the name starts with a diget. In that case Krita goes into a special mode to load an embedded document or so.

For developers: The problem is in KoStore line 594. Not sure what specification that is following.
Comment 5 Halla Rempt 2011-12-18 12:10:55 UTC
Outch! That looks like it's some sort of hack for old-style KOffice documents... I'd mark this bug as a calligra-common bug, but that would probably mean that I'd lose track of it.
Comment 6 Halla Rempt 2011-12-18 13:08:59 UTC
Git commit 8ff282b90d8f66c17f393bfa2ba89eeedc896c7d by Boudewijn Rempt.
Committed on 18/12/2011 at 14:06.
Pushed by rempt into branch 'master'.

Show the happy bunny!

Krita's use of KoStore is pretty old-fashioned, and we don't need the
name expansion used by the unfinished, 10-year old filter-in-filter
feature that presumably is the reason for doing weird things to paths
in a store of they start with a digit.

KoStore needs a thorough clean-up, but for now, setting disallowNameExpansion
is enough.

BUG:289242

M  +1    -0    krita/plugins/formats/odg/kis_odg_import.cc
M  +2    -1    krita/plugins/formats/ora/ora_converter.cc
M  +2    -0    krita/ui/kis_clipboard.cc
M  +1    -1    krita/ui/kis_mimedata.cpp

http://commits.kde.org/calligra/8ff282b90d8f66c17f393bfa2ba89eeedc896c7d