Bug 289047 - Add Context Menu for Breakpoint when clicking breakpoint mark
Summary: Add Context Menu for Breakpoint when clicking breakpoint mark
Status: RESOLVED FIXED
Alias: None
Product: kdevelop
Classification: Unclassified
Component: CPP Debugger (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR wishlist (vote)
Target Milestone: 4.2.3
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-15 16:14 UTC by Chris Bruner
Modified: 2012-01-15 10:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Bruner 2011-12-15 16:14:24 UTC
Version:           unspecified
OS:                Linux

Right clicking on a breakpoint should have a menu of options 
Enable/Disable
pass count
Condition
Thread
Action break
action log
action log call stack.

Reproducible: Didn't try



Expected Results:  
Action refers to what action should occur when the breakpoint is activated.
Comment 1 Niko Sams 2011-12-17 10:14:40 UTC
There is already a context menu for breakpoints in the Breakpoints tool view. Did you expect the menu in the icon border (where the red bug icon is shown)?

Also explain what you mean by those:
Thread
Action break
action log
action log call stack.
Comment 2 Chris Bruner 2011-12-17 16:07:25 UTC
Yes, right clicking on the red bug icon, should bring up the context menu. To me that would be more intuitive. 

thread would be used to specify which thread the breakpoint is applied to.  I don't know how valuable this would be, as I don't do much multi threading work, but I suspect that it could be very useful for someone trying to debug a multithreaded application.

Action log, would, instead of breaking, write the system state to the log file. Possibly with a predefined message. 

Action log call stack would, instead of breaking, write out the call stack to the log file.
Comment 3 Niko Sams 2011-12-17 18:56:42 UTC
Ok, I changed the title of this bug to add a context menu on the mark.
It should be easy to implement, KTextEditor provides a markContextMenuRequested method.

The other stuff should be separate bugs:
Afaik you can't have a breakpoint for a specific thread.
And this action log you describe... that would be tracepoints. Actually so far I always used qDebug instead, but might be useful.
Comment 4 Niko Sams 2012-01-15 10:28:49 UTC
Git commit 5a80aff6facc5048a0c9867bd86eae472635c187 by Niko Sams.
Committed on 15/01/2012 at 11:19.
Pushed by nsams into branch 'master'.

add context menu to breakpoint mark in kate icon border

Depends on the latest kate 4.8 version (without the menu will
not be shown)

Will not be in KDevelop 4.3 because of new strings.

M  +40   -1    debugger/breakpoint/breakpointmodel.cpp
M  +4    -0    debugger/breakpoint/breakpointmodel.h

http://commits.kde.org/kdevplatform/5a80aff6facc5048a0c9867bd86eae472635c187