Bug 288568 - The bottom panel is glitchy when you start maximized window in kde 4.8
Summary: The bottom panel is glitchy when you start maximized window in kde 4.8
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-09 14:44 UTC by Simonas
Modified: 2012-01-21 18:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot (90.33 KB, image/png)
2011-12-09 14:44 UTC, Simonas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simonas 2011-12-09 14:44:35 UTC
Created attachment 66551 [details]
Screenshot

Version:           unspecified (using Devel) 
OS:                Linux

As i know, when you have blur effect enabled and when you start maximized application (like web browser) the top of the panel should have a white accent. In kde 4.8 it doesnt redraw it correctly. When you start maximized window eventually in the panel theres no white accent, but when you click on e.g. kickoff menu, then the panel redraws itself correctly. Worse, when you click on some applet like kmix, it only redraws the area which kmix popup had.

Reproducible: Always

Steps to Reproduce:
Start maximized window, try to click on e.g kmix or klipper youll see that panel is redrawn

Actual Results:  
The panel wont be correctly redrawn

Expected Results:  
When i open maximized window, the panel should give white accent like it does with kde 4.7 without any redraws.

This problem existed in kde 4.6, but was fixed in kde 4.7, now its back in 4.8.
Comment 1 Martin Flöser 2011-12-10 11:37:34 UTC
*** Bug 277720 has been marked as a duplicate of this bug. ***
Comment 2 Philipp Knechtges 2011-12-10 11:51:52 UTC
Git commit b9e5a3a951f5967fa891dbe4a278be0c764414e4 by Philipp Knechtges.
Committed on 10/12/2011 at 11:28.
Pushed by knechtges into branch 'master'.

kwin: fixing some blur bugs

This should fix 2 issues with the blur effect:
- It is now sufficient to have a damaged EXPANDED blurArea to trigger
  an update of the caching texture.
- No glitches in cases where the taskbarthumbnail effect paints a
  thumbnail of a blurred window.

CCBUG: 288568

M  +7    -13   kwin/effects/blur/blur.cpp

http://commits.kde.org/kde-workspace/b9e5a3a951f5967fa891dbe4a278be0c764414e4
Comment 3 Philipp Knechtges 2011-12-21 22:17:26 UTC
Could you please close the bug if the commit fixes the bug for you?
Thanks.
Comment 4 Martin Flöser 2012-01-19 21:20:45 UTC
assuming it's fixed. If not please reopen.
Comment 5 Simonas 2012-01-21 18:56:17 UTC
Yes its fixed, sorry for late response.