Bug 286356 - Amarok: delete files from iPod doesn't free up space
Summary: Amarok: delete files from iPod doesn't free up space
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Collections/iPod iPhone (show other bugs)
Version: 2.4.3
Platform: Debian unstable Linux
: NOR normal (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-11 19:21 UTC by Jeffrey
Modified: 2011-12-20 11:05 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeffrey 2011-11-11 19:21:06 UTC
Version:           2.4.3 (using KDE 4.6.5) 
OS:                Linux

I've deleted a TON of files on my iPod (black 60GB iPod Video) to free up space, but 'df' doesn't show any long-term change in these disk space (the number does change a bit but it has not really moved from the 75MB Free, other than maybe 1MB in both directions, during the Delete activity).

Reproducible: Always

Steps to Reproduce:
Run from CLI 'watch -d df'
Delete files from iPod via Amarok
Notice the 'df' hasn't changed much.

Actual Results:  
Files are gone but there is no free space

Expected Results:  
Space should be free to put on different music but it's not working.

I've tried to unplug and replug the device a few times but the space hasn't changed.
Comment 1 Jeffrey 2011-11-11 19:31:30 UTC
these turned out to have been moved to /media/ipod/.Trash-1000/

I'd love to see Amarok either not do this, or offer to clean that up some how, perhaps when ejecting from Amarok.

Thanks for the great app!
Comment 2 Matěj Laitl 2011-11-12 10:54:35 UTC
Hi Jeffrey, thanks for your report.

The real problem is that the "Delete tracks" action in the context menu in fact sends these files to trash (located on the device), at least it correctly mentions this in the confirmation dialog. There is a hidden feature in Amarok: hold Shift while clicking the "Delete tracks" action and the files will skip the trash and will be deleted right away (with confirmation).

Also please note the files located in "device trash" are normally visible in the main Trash as long as the device is connected.

I do plan to split the actions so that it is more like in Dolphin, let's hope I will make it for the 2.5. release.
Comment 3 Matěj Laitl 2011-11-12 15:13:13 UTC
Git commit 3c2f14dd62241312275b5a5b821dba0a628a37ed by Matěj Laitl.
Committed on 12/11/2011 at 16:01.
Pushed by laitl into branch 'master'.

Separate delete and trash collection tree actions

The "delete" action was previously only accessible through holding
Shift when clicking Delete, which was secret, inconsistent and
inconvenient. The old shift + click behaviour is not preserved.

BUG: 286356
FIXED-IN: 2.5
GUI: Move to Trash action added to collection browser context menu
     Handbook needs updating.

M  +2    -0    ChangeLog
M  +32   -23   src/browsers/CollectionTreeView.cpp
M  +2    -1    src/browsers/CollectionTreeView.h

http://commits.kde.org/amarok/3c2f14dd62241312275b5a5b821dba0a628a37ed
Comment 4 Jeffrey 2011-11-12 18:11:07 UTC
I guess, when deleting from my iPod, I don't think if it as a general
storage device that I'd want to recover from, especially when I need to do
the delete via an app like Amarok or whatever else.  Can iTunes recover
files from .Trash-1000/ folder?  How would one recover these files within
Amarok?  If iTunes and Amarok both cannot recover from that location it may
be best to fully delete the files... just my 2cents.  Thanks for Amarok!
On Nov 12, 2011 7:13 AM, "Matěj Laitl" <matej@laitl.cz> wrote:

> https://bugs.kde.org/show_bug.cgi?id=286356
>
>
> Matěj Laitl <matej@laitl.cz> changed:
>
>           What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>             Status|NEW                         |RESOLVED
>   Version Fixed In|                            |2.5
>         Resolution|                            |FIXED
>
>
>
>
> --- Comment #3 from Matěj Laitl <matej laitl cz>  2011-11-12 15:13:13 ---
> Git commit 3c2f14dd62241312275b5a5b821dba0a628a37ed by Matěj Laitl.
> Committed on 12/11/2011 at 16:01.
> Pushed by laitl into branch 'master'.
>
> Separate delete and trash collection tree actions
>
> The "delete" action was previously only accessible through holding
> Shift when clicking Delete, which was secret, inconsistent and
> inconvenient. The old shift + click behaviour is not preserved.
>
> BUG: 286356
> FIXED-IN: 2.5
> GUI: Move to Trash action added to collection browser context menu
>     Handbook needs updating.
>
> M  +2    -0    ChangeLog
> M  +32   -23   src/browsers/CollectionTreeView.cpp
> M  +2    -1    src/browsers/CollectionTreeView.h
>
> http://commits.kde.org/amarok/3c2f14dd62241312275b5a5b821dba0a628a37ed
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
> You reported the bug.