Bug 285581 - Newly created path is invisible in Words, Tables and Stage
Summary: Newly created path is invisible in Words, Tables and Stage
Status: RESOLVED FIXED
Alias: None
Product: calligracommon
Classification: Applications
Component: path-shapes (show other bugs)
Version: 2.4-snapshots
Platform: Ubuntu Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Calligra Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-02 18:15 UTC by Marko Knöbl
Modified: 2012-04-30 18:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marko Knöbl 2011-11-02 18:15:26 UTC
Version:           2.4-snapshots (using KDE 4.7.2) 
OS:                Linux

When a new path is created in Words, Tables or Stage its colour has opacity 0 by default.
This is especially an issue when the "stroke and fill" docker is not visible because the cause of the problem is hard to spot.

In Karbon and Krita a newly created path has opacity 1.

Reproducible: Always

Steps to Reproduce:
Create a new document in Words, Tables or Stage.
Select "create path" from the "Tools" docker.
Try to draw a path.

Actual Results:  
The color of the created path has opacity 0. The path is invisible.

Expected Results:  
A visible path is created and shown.

I'm running Calligra Beta 3 from the Ubuntu PPA.
Comment 1 Halla Rempt 2012-04-16 14:20:15 UTC
Ack, and very irritating it is too!
Comment 2 Sven Langkamp 2012-04-30 18:12:40 UTC
Git commit 8887e9f9ae22934be9bfdc0121c367977f317135 by Sven Langkamp.
Committed on 30/04/2012 at 20:11.
Pushed by langkamp into branch 'master'.

intialize colors in resource manager

M  +4    -0    libs/flake/KoCanvasResourceManager.cpp

http://commits.kde.org/calligra/8887e9f9ae22934be9bfdc0121c367977f317135
Comment 3 Camilla Boemann 2012-04-30 18:16:00 UTC
Git commit ee0c1ee246f2483ca44d9ee9a50afbbd3c9eed14 by C. Boemann, on behalf of Sven Langkamp.
Committed on 30/04/2012 at 20:11.
Pushed by boemann into branch 'calligra/2.4'.

intialize colors in resource manager

M  +4    -0    libs/flake/KoCanvasResourceManager.cpp

http://commits.kde.org/calligra/ee0c1ee246f2483ca44d9ee9a50afbbd3c9eed14