Bug 284456 - Visual clue: show coordinates when marking an area of a picture.
Summary: Visual clue: show coordinates when marking an area of a picture.
Status: RESOLVED FIXED
Alias: None
Product: kolourpaint
Classification: Unclassified
Component: ui (show other bugs)
Version: Comes with KDE
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kolourpaint-support
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-19 12:10 UTC by Goran Brannstrom
Modified: 2012-05-13 13:04 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Goran Brannstrom 2011-10-19 12:10:03 UTC
Version:           Comes with KDE (using KDE 4.7.2) 
OS:                Linux

When you want to crop a picture its very difficult to see when the cursor moves from an area of the window outside the editing area and just enters let's say the left-most pixel column of the picture. I usually want to keep the width of a picture and only crop the top and bottom somewhat, and then I want to make sure I start cropping at the extreme left of the picture. As there is no visual clue when the cursor enters the editing area, such as coordinates being diplayed e.g, I often end up clicking just outside the picture and end up moving the whole Kolourpaint windows when I move the cursor to the right to mark what I want to include in my cropping. 

Reproducible: Sometimes

Steps to Reproduce:
Choose the rectangular marking tool. Then point and click-hold just to the left of the editing area. Then move to the right as if to mark up an area for editing.

Actual Results:  
The whole windows moves instead of the marking expanding to include your chosen area of the picture. This happens about 50% of the time, even if you have laser-guided fingers and 20-20 vision.

Expected Results:  
1) Nice if the application allowed a user to disable moving the whole window by click-dragging anywhere on the window, and instead must move it by clicking the top of the window. 2) Make it possible to turn on some "visual clue" in the editing area, such as the coordinates of the cursor, or top-left-corner/bottom-right corner being shown in the editing area, while the area for editing is being marked out.

This was not a problem in Kolourpaint bundled with KDE < 4.7. But I can't remember right now what the visual clue was. I know that the coordinates are shown in the bottom status field, but you can't move the cursor accurately in the editing area and look at the status down there at the same time. The visual clue must be in the area of focus of your eyes.
Comment 1 Goran Brannstrom 2011-11-09 21:03:34 UTC
Remembered what the visual clue was: The cursor used to change to a crosshair upon entering the editing area. A simple a very useful clue! Please bring me back the crosshair, pretty please?
Comment 2 Goran Brannstrom 2012-02-01 17:05:37 UTC
...with sugar on top? :-)
Comment 3 Martin Koller 2012-02-01 17:25:34 UTC
The selection cursor was changed to fix bug 116783.

You can do the following to solve your issue:
- Zoom in.
- Use the coordinates located in the statusbar.

The behaviour where the window is moved by clicking it anywhere is not kolourpaint specific; this is the style which does that (I think this is only done with the default style oxygen, but I'm not sure as I don't use it). Check your style settings if you can disable this behaviour or use a different style. There is nothing kolourpaint can do here.
Comment 4 Goran Brannstrom 2012-02-01 18:03:47 UTC
Thanks for your suggestion, but it does not really work well in reality. 

Why? Because you have to move the focus of your eye back and forth between the cursor and the status bar. You need to see when the cursor is correctly placed where the focus of your eye is. That is why changing the cursor depending on where it's pointed would be far superior, especially for high def pictures. 

I have used this tool for like thousands of hours and for editing more than 50,000 pictures, so I just thought someone might be interested in my suggestion. If not, then I'll just have to do without this feature.

Yes, I guess I might find some way to disable this move-the-whole-windows-feature, but I haven't found it yet. Also, that only solves half the problem.
Comment 5 Christoph Feck 2012-02-04 13:35:27 UTC
> disable this move-the-whole-windows-feature

Run "oxygen-settings", Widget Style > General tab > Window's drag mode: Drag windows from title bar only.
Comment 6 Goran Brannstrom 2012-02-04 17:44:58 UTC
Hi!

Thanks, that helps half-way at least!

/Goran


On Sat, Feb 4, 2012 at 14:35, Christoph Feck <christoph@maxiom.de> wrote:

> https://bugs.kde.org/show_bug.cgi?id=284456
>
>
> Christoph Feck <christoph@maxiom.de> changed:
>
>           What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>                 CC|                            |christoph@maxiom.de
>
>
>
>
> --- Comment #5 from Christoph Feck <christoph maxiom de>  2012-02-04
> 13:35:27 ---
> > disable this move-the-whole-windows-feature
>
> Run "oxygen-settings", Widget Style > General tab > Window's drag mode:
> Drag
> windows from title bar only.
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 7 Martin Koller 2012-02-04 19:02:24 UTC
Ok, I think I can make a fix which solves both requests - this one and the older bug:

I will use a hardcoded cursor shape which has exactly a 1 pixel wide crosshair so that you can
1) easily find the hot-spot in the middle regardless of what an artist thought might look nice for the standard crosshair cursor shape
2) the cursor will change when the mouse leaves the drawing area, so you again have the "visual clue"
Comment 8 Martin Koller 2012-02-04 19:08:07 UTC
Git commit bebf9ddfbfd5be3731953d6c9124aa9dd3f892f3 by Martin Koller.
Committed on 04/02/2012 at 20:05.
Pushed by mkoller into branch 'KDE/4.8'.

Use a hardcoded 1-pixel crosshair cursor for exactly seeing the hot-spot

M  +26   -1    tools/selection/kpAbstractSelectionTool_Create.cpp

http://commits.kde.org/kolourpaint/bebf9ddfbfd5be3731953d6c9124aa9dd3f892f3
Comment 9 Martin Koller 2012-02-04 19:10:41 UTC
Git commit e0c40e95637c30ec455824a15f2fe657bfc527e1 by Martin Koller.
Committed on 04/02/2012 at 20:05.
Pushed by mkoller into branch 'master'.

Use a hardcoded 1-pixel crosshair cursor for exactly seeing the hot-spot

M  +26   -1    tools/selection/kpAbstractSelectionTool_Create.cpp

http://commits.kde.org/kolourpaint/e0c40e95637c30ec455824a15f2fe657bfc527e1
Comment 10 Goran Brannstrom 2012-02-05 12:55:42 UTC
That would be greatly appreciated!

In the future, an effect like lowering the brightness of the area not selected would be ultra cool. But I know, that's more like an enhance than a bug correction. 

Many thanks!
Comment 11 Goran Brannstrom 2012-03-14 20:47:06 UTC
Hi!

Not to be ungrateful or anything but...
It is now impossible to see the hair-cross in a dark area.
Best solution would be  a black cross with white outline, or vice versa.

/Goran

On Sat, Feb 4, 2012 at 18:44, Goran Brannstrom <goranbr@gmail.com> wrote:

> Hi!
>
> Thanks, that helps half-way at least!
>
> /Goran
>
>
>
> On Sat, Feb 4, 2012 at 14:35, Christoph Feck <christoph@maxiom.de> wrote:
>
>> https://bugs.kde.org/show_bug.cgi?id=284456
>>
>>
>> Christoph Feck <christoph@maxiom.de> changed:
>>
>>           What    |Removed                     |Added
>>
>> ----------------------------------------------------------------------------
>>                 CC|                            |christoph@maxiom.de
>>
>>
>>
>>
>> --- Comment #5 from Christoph Feck <christoph maxiom de>  2012-02-04
>> 13:35:27 ---
>> > disable this move-the-whole-windows-feature
>>
>> Run "oxygen-settings", Widget Style > General tab > Window's drag mode:
>> Drag
>> windows from title bar only.
>>
>> --
>> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
>> ------- You are receiving this mail because: -------
>> You reported the bug.
>>
>
>
>
> --
> ** The funniest thing about this signature is that by the time you realize
> it doesn't say anything it's too late to stop reading it. **
>
Comment 12 Kai Uwe Broulik 2012-04-03 10:57:45 UTC
I just wondered what happened and then saw this commit: The crosshair is impossible to spot on a dark/black area :(
Isn't it possible to use a crosshair that has "inverted" colors?
Comment 13 Goran Brannstrom 2012-04-03 12:30:44 UTC
Thanks for your input, Mr Broulik.

Yes a white cross-hair on dark areas and a black one in light areas of an image might work. The same goes for the line marking the selected area. The ideal would be to have a dashed line with alternately white and black dashes, or to darken out the un-selected area.

However, changing the cursor for every pixel it traverses might give a very flickering impression as you move the cursor across an image. You might not want that. 

At work I use an older version of Kolourpaint 4.6.5 and this version has a very clear cross-hair, made up of a white cross-hair with a black outline. Works like a charm! it would be nice to revert to this high-visibility cross-hair.

Ps. Gimp uses a black cross-hair with a white outline, and the crosshairs do not meet in the middle in gimp. This would also work.

/Goran
Comment 14 Martin Koller 2012-05-13 13:01:36 UTC
Git commit 2b823873ef13e03ce5adf2e499af0e3d49a5fa53 by Martin Koller.
Committed on 13/05/2012 at 14:58.
Pushed by mkoller into branch 'master'.

make the crosshair cursor more visible by using a black crosshair with white outline.

M  +19   -18   tools/selection/kpAbstractSelectionTool_Create.cpp

http://commits.kde.org/kolourpaint/2b823873ef13e03ce5adf2e499af0e3d49a5fa53
Comment 15 Martin Koller 2012-05-13 13:04:22 UTC
Git commit 1476efa8ebab1f85e8fc78cb8126ba544a1a91f8 by Martin Koller.
Committed on 13/05/2012 at 14:58.
Pushed by mkoller into branch 'KDE/4.8'.

make the crosshair cursor more visible by using a black crosshair with white outline.

M  +19   -18   tools/selection/kpAbstractSelectionTool_Create.cpp

http://commits.kde.org/kolourpaint/1476efa8ebab1f85e8fc78cb8126ba544a1a91f8