Bug 28072 - Should not sign messages when saving to drafts folder
Summary: Should not sign messages when saving to drafts folder
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: encryption (show other bugs)
Version: unspecified
Platform: unspecified Other
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 69703 (view as bug list)
Depends on:
Blocks:
 
Reported: 2001-07-04 05:48 UTC by Ivan E. Moore II
Modified: 2007-09-14 12:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan E. Moore II 2001-07-03 18:04:23 UTC
(*** This bug was imported into bugs.kde.org ***)

Package: kmail
Version: 4:2.1.1-7
Severity: normal

(Originally submitted to the Debian BTS by "Eray Ozkural (exa)" <erayo@cs.bilkent.edu.tr> as Bug#103201)

Well I think the subject is clear. When I turn on automatic signing
saving a message to drafts folder will result in a signed message being
saved. Later when you continue writing the message you have to remove the sign
manually and sign when you really send it. It should not sign messages
saved to drafts.
Comment 1 Ingo Kl 2001-07-04 17:11:47 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Tuesday 3. July 2001 20:04 Ivan E. Moore II wrote:
> Well I think the subject is clear. When I turn on automatic signing
> saving a message to drafts folder will result in a signed message
> being saved. Later when you continue writing the message you have to
> remove the sign manually and sign when you really send it. It should
> not sign messages saved to drafts.

In the current developer version the PGP signature is automagically 
removed when you continue writing the message. This means there is no 
need to not automatically sign messages which are saved in the drafts 
folder and therefore I close your bug report.
If you don't want to sign messages which you save in the drafts folder 
you should turn off signing before saving the message.

Regards
Ingo
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.4 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE7Q05TGnR+RTDgudgRAo5MAJ9gYBS5+iQgZmg+mi7WHUxe0iGd5QCg1mVl
yE8GrhsMeCcUOWE6BxylRkE=
=BC8b
-----END PGP SIGNATURE-----
Comment 2 Magnus Von K 2001-07-04 19:50:39 UTC
>> Well I think the subject is clear. When I turn on automatic signing
>> saving a message to drafts folder will result in a signed message
>> being saved. Later when you continue writing the message you have to
>> remove the sign manually and sign when you really send it. It should
>> not sign messages saved to drafts.

IK> In the current developer version the PGP signature is automagically 
IK> removed when you continue writing the message. This means there is no 
IK> need to not automatically sign messages which are saved in the drafts 
IK> folder and therefore I close your bug report.
IK> If you don't want to sign messages which you save in the drafts folder 
IK> you should turn off signing before saving the message.

That's not true. I think it's very annoying if you have to enter your
passphrase just to get it removed again when you reopen the message to
edit it again. That's not efficient and therefore not good design.

Can I reopen this bug somehow? Or should I resubmit it? Or will you
reopen it?

-M

-------  Magnus von Köller   <magnus@vonkoeller.de> ------
 Georg-Westermann-Allee 76 / 38104 Braunschweig / Germany
   Phone: +49-(0)531/2094886 Mobile: +49-(0)179/4562940

 lp1 on fire (One of the more obfuscated kernel messages)
Comment 3 gtsemailser 2001-11-19 01:36:07 UTC
GT TONER SUPPLIES


ORDER BY PHONE PLEASE CALL 770-623-9780
ORDER BY EMAIL: gtsupplies@cable.net.co
EMAIL REMOVAL:  gtsemailser@cable.net.co


LASER PRINTER TONER CARTRIDGES COPIER AND FAX CARTRIDGES
SAVE UP TO 40% FROM RETAIL PRICE.

UNIVERSITY AND/OR SCHOOL PURCHASE ORDERS WELCOME. (NO CREDIT APPROVAL REQUIRED)

ALL OTHER PURCHASE ORDERS REQUESTS REQUIRE CREDIT APPROVAL.

PAY BY CHECK C.O.D OR PURCHASE ORDER (NET 30 DAYS).

FOR THOSE OF YOU WHO HAVE ANY QUESTION ABOUT OUR COMPANY PLEASE EMAIL US AT
gtsinfo@cable.net.co


OUR NEW LASER PRINTER TONER CARTRIDGE PTICES ARE AS FOLLOWS: (PLEASE ORDER
BY ITEM NUMBER)

ITEM    MAKE        MODEL                       PRICE

1---------- HP--------------------LASERJET SERIES 4L 4P
(74A)-----------------------------  $39.00
2---------- HP--------------------LASERJET SERIES 1100
(92A)-------------------------------    $39.00
3---------- HP--------------------LASERJET SERIES 2
(95A)------------------------------------$30.00
4---------- HP-------------------   LASERJET SERIES 2P
(75A)---------------------------------- $49.00
5---------- HP-------------------   LASERJET SERIES 5P5MP6P6MP
(03A)----------------   $39.00
6---------- HP-------------------   LASERJET SERIES 5SI800
(09A)----------------------------$89.00
7---------- HP--------------------LASERJET SERIES 2100
(96A)-------------------------------    $65.00
8---------- HP--------------------LASERJET SERIES 8100
(82X)-------------------------------    $129.00
9---------- HP--------------------LASERJET SERIES 5L6L
(3906A)---------------------------  $35.00
10---------HP--------------------LASERJET SERIES
4V------------------------------------------    $89.00
11---------HP--------------------LASERJET SERIES 4000
(27X)-------------------------------    $65.00
12---------HP--------------------LASERJET SERIES 3SI4SI
(91A)----------------------------   $49.00
13---------HP--------------------LASERJET SERIES 44M55M
(98A)-----------------------    $40.00
14---------HP--------------------LASERJET SERIES 5000
(29X)--------------------------------$89.00
15---------HP--------------------LASERFAX 500 700 (FX1)
------------------------------------$44.00
16---------HP--------------------LASERFAX 5000 7000
(FX2)---------------------------------  $49.00
17---------HP--------------------LASERFAX
(FX3)-----------------------------------------------    $49.00
18---------HP--------------------LASERFAX
(FX4)-----------------------------------------------    $49.00

19---------LEXMARK--------  OPTRA 40194029 HIGH
YIELD------------------------------ $79.00
20---------LEXMARK--------  OPTRA R 40394049 HIGH
YIELD---------------------------    $99.00
21---------LEXMARK--------  OPTRA
E-----------------------------------------------------------$49.00
22---------LEXMARK---------OPTRA
N----------------------------------------------------------$105.00
23---------LEXMARK--------  OPTRA
S-----------------------------------------------------------$145.00
24---------LEXMARK--------  OPTRA
T-----------------------------------------------------------$180.00

25---------EPSON--------------  ACTION LASER
7000750080009000----------------------   $99.00
26---------EPSON--------------  ACTION LASER
10001500------------------------------------$99.00

27---------PANASONIC-----   NEC SERIES 2 MODELS 90 AND
95------------------------  $99.00

28---------APPLE--------------  LASER WRITER PRO
60016/600----------------------------  $40.00
29---------APPLE--------------  LASER WRITER SELECT
300320360----------------------$64.00
30---------APPLE--------------  LASER WRITER 300
320--------------------------------------   $49.00
31---------APPLE--------------  LASER WRITER NT
2NT-------------------------------------    $49.00
32---------APPLE--------------  LASER WRITER
12/640----------------------------------------  $69.00

33---------CANON------------    FAX LASERCLASS 4000
(FX3)------------------------------ $49.00
34---------CANON------------    FAX LASERCLASS 500060007000
(FX2)----------------   $44.00
35---------CANON------------    LASERFAX 50007000
(FX2)---------------------------------  $44.00
36---------CANON------------    LASERFAX 85009000
(FX4)---------------------------------  $44.00
37---------CANON------------    COPIER PC36RE7 & 11
(A30)-------------------------------    $59.00
38---------CANON------------    COPIER 300320700720 AND 760
(E-40)------------------    $79.00

30 DAY UNLIMITED WARRANTY INCLUDED ON ALL PRODUCTS.

IF YOU ARE ORDERING BY E-MAIL OR C.O.D. PLEASE FILL OUT AN ORDER FORM WITH
THE FOLLOWING INFORMATION:

PHONE NUMBER
COMPANY NAME
FIRST AND LAST NAME
STREET ADDRESS
CITY STATE ZIP CODE

IF YOU ARE ORDERING BY PURCHASE ORDER PLEASE FILL OUT AN ORDER FORM WITH THE
FOLLOWING INFORMATION:

PURCHASE ORDER NUMBER
PHONE NUMBER
COMPANY OR SCHOOL NAME
SHIPPING ADDRESS AND BILLING ADDRESS
CITY STATE ZIP CODE

ALL TRADE MARKS AND BRAND NAMES LISTED ABOVE ARE PROPERTY OF THE RESPECTIVE
HOLDERS AND USED FOR DESCRIPTIVE PURPOSES ONLY.
Comment 4 Ingo Klöcker 2003-12-06 20:21:13 UTC
*** Bug 69703 has been marked as a duplicate of this bug. ***
Comment 5 Luke-Jr 2003-12-06 21:01:04 UTC
Can there at least be an option added to save the state of the Sign/Encrypt options for the mail, but not actually sign/encrypt the message when it is only saved as a draft?
Comment 6 Marc Mutz 2004-04-08 11:22:16 UTC
You can disable signing/encryption when saving in drafts now (at least aegypten_branch, maybe HEAD, too already).