Bug 279675 - konqueror does not open certain files from internet sites (bug 267345)
Summary: konqueror does not open certain files from internet sites (bug 267345)
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Unclassified
Component: general (show other bugs)
Version: 4.7
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dawit Alemayehu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-08 17:50 UTC by Ferdinand Gassauer
Modified: 2013-01-11 08:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ferdinand Gassauer 2011-08-08 17:50:38 UTC
Version:           4.7 (using KDE 4.7.0) 
OS:                Linux

konqueror does not recognize filetype by extension

see 
https://bugs.kde.org/show_bug.cgi?id=267345

Reproducible: Sometimes

Steps to Reproduce:
https://bugs.kde.org/show_bug.cgi?id=267345

Actual Results:  
https://bugs.kde.org/show_bug.cgi?id=267345

Expected Results:  
open file
Comment 1 Dawit Alemayehu 2011-08-09 22:46:59 UTC
Git commit bd53435c033c4674d30987e8646443649b9da75b by Dawit Alemayehu.
Committed on 10/08/2011 at 00:45.
Pushed by adawit into branch 'KDE/4.7'.

If the mime-type is the default one (application/octet-stream), use the
suggested file name to determine the content's mime-type.

BUG: 279675
REVIEW: 102256

M  +14   -5    kparts/browseropenorsavequestion.cpp

http://commits.kde.org/kdelibs/bd53435c033c4674d30987e8646443649b9da75b
Comment 2 David Faure 2011-08-10 00:34:49 UTC
Git commit b4f96a8f74431223b539da175c2ae7d0bc4322bc by David Faure, on behalf of Dawit Alemayehu.
Committed on 10/08/2011 at 00:45.
Pushed by dfaure into branch 'frameworks'.

If the mime-type is the default one (application/octet-stream), use the
suggested file name to determine the content's mime-type.

BUG: 279675
REVIEW: 102256
(cherry picked from commit bd53435c033c4674d30987e8646443649b9da75b)

M  +14   -5    kparts/browseropenorsavequestion.cpp

http://commits.kde.org/kdelibs/b4f96a8f74431223b539da175c2ae7d0bc4322bc
Comment 3 Dawit Alemayehu 2011-12-05 07:08:59 UTC
Git commit 93517f75ca903a4994c22cf680b4846639ee39ac by Dawit Alemayehu.
Committed on 05/12/2011 at 07:58.
Pushed by adawit into branch 'KDE/4.7'.

Show the correct mime type in the dialog box when the mime-type is determined
from the suggested filename.

This commits adds back the missing portion from the last commit, bd53435c.

CCBUG: 279675

M  +7    -3    kparts/browseropenorsavequestion.cpp

http://commits.kde.org/kdelibs/93517f75ca903a4994c22cf680b4846639ee39ac
Comment 4 David Faure 2013-01-11 08:47:15 UTC
Git commit 99175ed16914d4a1e1028b9dadb4fd01fc29b446 by David Faure.
Committed on 08/01/2013 at 21:32.
Pushed by dfaure into branch 'KDE/4.10'.

Rework fix for bug 279675 so that the new mimetype is used by KRun too.

When the mimetype has to be refined from the url-filename or suggested-filename,
it's not enough to show the user, we have to also pass it on to the application
and to KRun. Otherwise clicking "open with KWrite" can end up not doing anything,
due to the service->hasMimeType() check in KRun. It also didn't benefit from
the turning of shellscript into text/plain in BrowserRun::handleNonEmbeddable
since the mimetype fixup was done afterwards.
REVIEW: 108277

M  +3    -24   kparts/browseropenorsavequestion.cpp
M  +16   -0    kparts/browserrun.cpp

http://commits.kde.org/kdelibs/99175ed16914d4a1e1028b9dadb4fd01fc29b446