Bug 279263 - Add a way to add the recently played tracks to the playlist
Summary: Add a way to add the recently played tracks to the playlist
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Context View/Current Track (show other bugs)
Version: 2.4-GIT
Platform: unspecified All
: NOR wishlist with 5 votes (vote)
Target Milestone: 2.5
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-03 08:09 UTC by Sven Krohlas
Modified: 2013-07-26 16:19 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.8


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Krohlas 2011-08-03 08:09:17 UTC
Version:           2.4-GIT
OS:                All

The current track applet shows a list of recently played tracks when Amarok is in stopped state. We should add a way to add those (drag and drop/context menu entry) to the playlist.

Reproducible: Didn't try



Expected Results:  
-
Comment 1 Konrad Zemek 2013-07-26 16:19:25 UTC
Git commit 5bfcf25fa06fc09c9bc951c7f9bf05dc5f6d66a9 by Konrad Zemek.
Committed on 23/07/2013 at 09:55.
Pushed by kzemek into branch 'master'.

Reimplement RecentlyPlayedListWidget

Rewrote RecentlyPlayedListWidget from the basics. There was a major
inconsistency in this widget, where tracks were added to it if they were
recently played at all, but the time shown was the "Last Played"
statistic which is only updated after whole song is played. This
caused gravely incorrect data to be displayed (see bug 302485).

There were two different methods of solving the inconsistency: focusing
on the "Last Played" time, and adding songs to the widget only if the
"Last Played" changed; and focusing on recent plays completely
disregarding "Last Played". I opted for the latter as I felt it fits the
widget's nature better.

Because we can't rely on already available data, the widget needs to do
its own housekeeping. It saves its data on shutdown, to be restored
on next startup. One other major benefit of this approach is that
widget's data remains correct even if collections change, while
previously tracks from removed collections would disappear.

Finally, I added the feature to add tracks to playlist directly from the
widget, provided that the track exists.
Related: bug 302485, bug 296090
FIXED-IN: 2.8
REVIEW: 111655

M  +6    -0    ChangeLog
M  +156  -139  src/context/widgets/RecentlyPlayedListWidget.cpp
M  +51   -15   src/context/widgets/RecentlyPlayedListWidget.h

http://commits.kde.org/amarok/5bfcf25fa06fc09c9bc951c7f9bf05dc5f6d66a9