Bug 278896 - Calligratables crashes when importing just ANY document
Summary: Calligratables crashes when importing just ANY document
Status: RESOLVED FIXED
Alias: None
Product: calligrasheets
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: HI crash (vote)
Target Milestone: ---
Assignee: Calligra Sheets (KSpread) Bugs
URL:
Keywords:
: 309599 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-30 23:36 UTC by Dyrver Eriksson
Modified: 2013-03-04 04:23 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
some old fake accounting transfer. (249 bytes, application/octet-stream)
2011-07-30 23:39 UTC, Dyrver Eriksson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dyrver Eriksson 2011-07-30 23:36:50 UTC
Application: calligratables (2.4 Alpha 3)
KDE Platform Version: 4.7.00 (4.7.0)
Qt Version: 4.7.3
Operating System: Linux 2.6.39-ARCH i686
Distribution: "Arch Linux"

-- Information about the crash:
- What I was doing when the application crashed:
Imported a tiny skv into Tables I found and it just crashes as soon I press OK no matter what setting I use it seems. Submitting the file as well.
- Custom settings of the application:
None that I am aware of so Default settings.
Built about 5 or 6 hours ago, last commit to calligra-git before I compiled the whole suite was titled "Support the 3rd param of the ceiling function"

The crash can be reproduced every time.

-- Backtrace:
Application: Tables (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb57d8b60 (LWP 29714))]

Thread 2 (Thread 0xad9acb70 (LWP 29715)):
#0  0xb5c6cd10 in clock_gettime () from /lib/librt.so.1
#1  0xb6e10425 in ?? () from /usr/lib/libQtCore.so.4
#2  0xb6ee2e26 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb6ee317a in ?? () from /usr/lib/libQtCore.so.4
#4  0xb6ee19c3 in ?? () from /usr/lib/libQtCore.so.4
#5  0xb6ee1a5d in ?? () from /usr/lib/libQtCore.so.4
#6  0xb5bbb1ec in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#7  0xb5bbc067 in ?? () from /usr/lib/libglib-2.0.so.0
#8  0xb5bbc6da in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#9  0xb6ee24a7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#10 0xb6eb31fd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#11 0xb6eb3441 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#12 0xb6db6abb in QThread::exec() () from /usr/lib/libQtCore.so.4
#13 0xb6e93d9d in ?? () from /usr/lib/libQtCore.so.4
#14 0xb6db9913 in ?? () from /usr/lib/libQtCore.so.4
#15 0xb6d43c77 in start_thread () from /lib/libpthread.so.0
#16 0xb613443e in clone () from /lib/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb57d8b60 (LWP 29714)):
[KCrash Handler]
#7  0xb644318a in QWidget::setParent(QWidget*) () from /usr/lib/libQtGui.so.4
#8  0xb09a8317 in ?? () from /usr/lib/libkomain.so.8
#9  0xb09561d8 in KoDockerManager::newOptionWidgets(QList<QWidget*> const&) () from /usr/lib/libkomain.so.8
#10 0xb09565ee in KoDockerManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkomain.so.8
#11 0xb6eba5ad in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#12 0xb6ec935a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#13 0xb0434445 in KoCanvasControllerWidget::toolOptionWidgetsChanged(QList<QWidget*> const&) () from /usr/lib/libflake.so.8
#14 0xb0434473 in KoCanvasControllerWidget::setToolOptionWidgets(QList<QWidget*> const&) () from /usr/lib/libflake.so.8
#15 0xb0446e04 in KoToolManager::Private::postSwitchTool(bool) () from /usr/lib/libflake.so.8
#16 0xb04481dd in KoToolManager::Private::switchTool(KoToolBase*, bool) () from /usr/lib/libflake.so.8
#17 0xb0449813 in KoToolManager::Private::switchTool(QString const&, bool) () from /usr/lib/libflake.so.8
#18 0xb0449bf0 in KoToolManager::switchToolRequested(QString const&) () from /usr/lib/libflake.so.8
#19 0xaeec5506 in Calligra::Tables::View::finishLoading() () from /usr/lib/libcalligratablescommon.so.8
#20 0xaeecd465 in Calligra::Tables::View::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libcalligratablescommon.so.8
#21 0xb6eba5ad in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#22 0xb6ec935a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#23 0xb6ed0c75 in ?? () from /usr/lib/libQtCore.so.4
#24 0xb6ed0d2c in ?? () from /usr/lib/libQtCore.so.4
#25 0xb6ecc284 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#26 0xb63e5084 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#27 0xb63ea433 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#28 0xb75d08b1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#29 0xb6eb41be in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#30 0xb6ee4588 in ?? () from /usr/lib/libQtCore.so.4
#31 0xb6ee1a92 in ?? () from /usr/lib/libQtCore.so.4
#32 0xb5bbbc4f in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#33 0xb5bbc3b0 in ?? () from /usr/lib/libglib-2.0.so.0
#34 0xb5bbc6da in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#35 0xb6ee244a in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#36 0xb64986ba in ?? () from /usr/lib/libQtGui.so.4
#37 0xb6eb31fd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#38 0xb6eb3441 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#39 0xb6eb7bad in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#40 0xb63e2ed4 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#41 0xb51fc5ad in kdemain () from /usr/lib/libkdeinit4_calligratables.so
#42 0x0804f29a in _start ()

Reported using DrKonqi
Comment 1 Dyrver Eriksson 2011-07-30 23:39:02 UTC
Created attachment 62354 [details]
some old fake accounting transfer.

See if you can import this without issues :)
Comment 2 Sebastian Sauer 2011-08-01 16:59:26 UTC
This doesn't only happen with .skv files. Importing/loading that attached skv file direct using "calligratables ~/bokf_trans_198209258956.skv works as expected but as soon as I already have a calligratables instance and try to use File=>Import it crashes with any document including skv and ods. 

Updated backtrace;

[KCrash Handler]
#6  0x00007f90a74cc488 in QWidget::window() const () from /usr/lib64/libQtGui.so.4
#7  0x00007f90a74df84a in QWidget::setParent(QWidget*, QFlags<Qt::WindowType>) () from /usr/lib64/libQtGui.so.4
#8  0x00007f90a74e0142 in QWidget::setParent(QWidget*) () from /usr/lib64/libQtGui.so.4
#9  0x00007f90abfc8c3d in KoToolDocker::Private::recreateLayout (this=0xa6fe00, optionWidgetList=...) at /home/snoopy/src/calligra/libs/main/KoToolDocker.cpp:77
#10 0x00007f90abfc85af in KoToolDocker::setOptionWidgets (this=0xa57630, optionWidgetList=...) at /home/snoopy/src/calligra/libs/main/KoToolDocker.cpp:269
#11 0x00007f90abf6e980 in KoDockerManager::newOptionWidgets (this=0xa5a5c0, optionWidgetList=...) at /home/snoopy/src/calligra/libs/main/KoDockerManager.cpp:168
#12 0x00007f90abf6ea98 in KoDockerManager::qt_metacall (this=0xa5a5c0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fffb9a021d0) at /home/snoopy/src/build/calligra/libs/main/KoDockerManager.moc:78
#13 0x00007f90a6872a5f in QMetaObject::activate (sender=0x168d410, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffb9a021d0) at kernel/qobject.cpp:3278
#14 0x00007f90ab0ca2a1 in KoCanvasControllerWidget::toolOptionWidgetsChanged (this=0x168d410, _t1=...) at /home/snoopy/src/build/calligra/libs/flake/KoCanvasControllerWidget.moc:97
#15 0x00007f90ab0c9615 in KoCanvasControllerWidget::setToolOptionWidgets (this=0x168d410, widgetMap=...) at /home/snoopy/src/calligra/libs/flake/KoCanvasControllerWidget.cpp:534
#16 0x00007f90ab0dd637 in KoToolManager::Private::postSwitchTool (this=0xe76990, temporary=false) at /home/snoopy/src/calligra/libs/flake/KoToolManager.cpp:385
#17 0x00007f90ab0dc3f3 in KoToolManager::Private::switchTool (this=0xe76990, tool=0x1841e00, temporary=false) at /home/snoopy/src/calligra/libs/flake/KoToolManager.cpp:263
#18 0x00007f90ab0dc77e in KoToolManager::Private::switchTool (this=0xe76990, id=..., temporary=false) at /home/snoopy/src/calligra/libs/flake/KoToolManager.cpp:289
#19 0x00007f90ab0e1130 in KoToolManager::switchToolRequested (this=0xe768d0, id=...) at /home/snoopy/src/calligra/libs/flake/KoToolManager.cpp:856
#20 0x00007f909491f4ea in Calligra::Tables::View::finishLoading (this=0x915d70) at /home/snoopy/src/calligra/tables/part/View.cpp:1112
Comment 3 Sebastian Sauer 2011-08-01 21:00:32 UTC
The problem is that the CellToolOptionWidget instance remembered in the KoToolBase is deleted in between on calling setRootDocument;

#0  Calligra::Tables::CellToolOptionWidget::~CellToolOptionWidget (this=0xa237e0, 
    __in_chrg=<value optimized out>)
    at /home/snoopy/src/calligra/tables/ui/CellToolOptionWidget.cpp:105
#1  0x00007fffe02c76d6 in Calligra::Tables::CellToolOptionWidget::~CellToolOptionWidget (this=
    0xa237e0, __in_chrg=<value optimized out>)
    at /home/snoopy/src/calligra/tables/ui/CellToolOptionWidget.cpp:106
#2  0x00007ffff69e6f15 in qDeleteAll<QList<QWidget*>::const_iterator> (begin=..., end=...)
    at /usr/include/QtCore/qalgorithms.h:322
#3  0x00007ffff69e68bc in qDeleteAll<QList<QWidget*> > (c=...)
    at /usr/include/QtCore/qalgorithms.h:330
#4  0x00007ffff69e6489 in KoToolBasePrivate::~KoToolBasePrivate (this=0xefafa0, 
    __in_chrg=<value optimized out>) at /home/snoopy/src/calligra/libs/flake/KoToolBase_p.h:57
#5  0x00007ffff69e51b2 in KoToolBase::~KoToolBase (this=0xefaf70, 
    __in_chrg=<value optimized out>) at /home/snoopy/src/calligra/libs/flake/KoToolBase.cpp:62
#6  0x00007ffff6a7cc68 in KoInteractionTool::~KoInteractionTool (this=0xefaf70, 
    __in_chrg=<value optimized out>)
    at /home/snoopy/src/calligra/libs/flake/tools/KoInteractionTool.cpp:33
#7  0x00007fffe02a66d0 in Calligra::Tables::CellToolBase::~CellToolBase (this=0xefaf70, 
    __in_chrg=<value optimized out>) at /home/snoopy/src/calligra/tables/ui/CellToolBase.cpp:857
#8  0x00007fffe0258f16 in Calligra::Tables::CellTool::~CellTool (this=0xefaf70, 
    __in_chrg=<value optimized out>) at /home/snoopy/src/calligra/tables/part/CellTool.cpp:104
#9  0x00007fffe0258f48 in Calligra::Tables::CellTool::~CellTool (this=0xefaf70, 
    __in_chrg=<value optimized out>) at /home/snoopy/src/calligra/tables/part/CellTool.cpp:107
#10 0x00007ffff69ff045 in KoToolManager::Private::detachCanvas (this=0xdd9ce0, controller=
    0xdd87b8) at /home/snoopy/src/calligra/libs/flake/KoToolManager.cpp:458
#11 0x00007ffff6a01f14 in KoToolManager::removeCanvasController (this=0xdd9c20, controller=
    0xdd87b8) at /home/snoopy/src/calligra/libs/flake/KoToolManager.cpp:833
#12 0x00007fffe027c476 in Calligra::Tables::View::~View (this=0xb1d3f0, 
    __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>)
    at /home/snoopy/src/calligra/tables/part/View.cpp:648
#13 0x00007fffe027c566 in Calligra::Tables::View::~View (this=0xb1d3f0, 
    __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>)
    at /home/snoopy/src/calligra/tables/part/View.cpp:655
#14 0x00007ffff78c1ae3 in KoMainWindow::setRootDocument (this=0x963a40, doc=0x1367440)
    at /home/snoopy/src/calligra/libs/main/KoMainWindow.cpp:496
#15 0x00007ffff78c36aa in KoMainWindow::slotLoadCompleted (this=0x963a40)
    at /home/snoopy/src/calligra/libs/main/KoMainWindow.cpp:711
#16 0x00007ffff78cbd27 in KoMainWindow::qt_metacall (this=0x963a40, _c=
    QMetaObject::InvokeMetaMethod, _id=34, _a=0x7fffffffb600)
    at /home/snoopy/src/build/calligra/libs/main/KoMainWindow.moc:175
#17 0x00007ffff2193a5f in QMetaObject::activate (sender=0x1367440, m=<value optimized out>, 
    local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007ffff5181562 in KParts::ReadOnlyPartPrivate::openLocalFile() ()
   from /usr/lib64/libkparts.so.4
Comment 4 Sebastian Sauer 2011-08-01 22:31:38 UTC
Fixed with 76ae2c395075d42fca26430b28554393f0818400
Comment 5 Jekyll Wu 2013-03-04 04:23:11 UTC
*** Bug 309599 has been marked as a duplicate of this bug. ***