Bug 277760 - KDE 4.7 RC1/2: Some apps (amarok, kopete, bluedevil) don't remember their settings
Summary: KDE 4.7 RC1/2: Some apps (amarok, kopete, bluedevil) don't remember their set...
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kdecore (show other bugs)
Version: 4.7
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 278300 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-14 13:34 UTC by S.Trzmiel
Modified: 2011-08-11 10:33 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S.Trzmiel 2011-07-14 13:34:43 UTC
Version:           4.7 (using Devel) 
OS:                Linux

Actually their configuration window is displayed with default values selected.

Example:
 - amarok here is configured to not display osd and use system notification. Untill configuration window wasn't open application respects my settings. 
But if I go to "settings->configure Amarok/Notification" following options are enabled:
  - use on-screen display (OSD)
  - use custom colors
  - custom color: red

instead of everything but "use system notifications" set to off.

I observed similar behaviour in some other apps including Kopete and BlueDevil KCM.

Purging config files won't solve the issue (removed all config dirs (~/.kde, ~/.config, ~/.local of my test user before login).
Because it happens with few independent apps I  believe it's kdelibs problem

Reproducible: Always

Steps to Reproduce:
1. Start any of the affected apps
2. Go to settings->configure and set some options (like systray icons visibility etc..) and apply settings.
3. Open configuration window once again

Actual Results:  
Configuration window shows different settings that were selected. If user  applies settings, application uses new (wrong) settings

Expected Results:  
Configuration window shows correct settings applied by the user.
Comment 1 Rex Dieter 2011-07-14 13:44:39 UTC
I experienced this testing 4.6.90, but not with 4.6.95.  What version(s) have you tried?
Comment 2 S.Trzmiel 2011-07-14 13:50:07 UTC
As in topic: KDE 4.7 RC1/2 that means 4.6.90 and 4.6.95 ;)
Comment 3 Rex Dieter 2011-07-14 13:57:18 UTC
Nevermind, testing fail.  

I rechecked with several apps, amarok, kopete (kdenetwork-4.6.95), and these are not saving their settings properly.  confirmed.

Other apps did work ok, including k3b, konsole, konqueror.

Strange.
Comment 4 Christoph Feck 2011-07-15 14:37:19 UTC
Cannot reproduce on today's master. I only tested the "Configure Amarok/Notification" page, and settings there, including custom color, delay etc. are saved correctly across invokations.
Comment 5 John 2011-07-18 19:41:29 UTC
Using 4.6.95 ~/.xsession-errors is showing many lines similar to the following when opening the configuration dialog:

kopete(2143)/kdeui (KConfigDialogManager) KConfigDialogManager::setProperty: QCheckBox  widget not handled!

I am guessing it's related.
Comment 6 Christoph Feck 2011-07-18 22:52:00 UTC
Is this using Qt 4.8?
Comment 7 John 2011-07-18 23:26:44 UTC
I don't know about the others but i am (qt-4.8.0-0.1.tp.fc15.x86_64 from kde-redhat). I forgot all about that update. I will try downgrading to whatever the latest 4.7 is tomorrow and see if that fixes things.
Comment 8 Rex Dieter 2011-07-19 00:32:57 UTC
I tested using qt-4.7.3
Comment 9 Christoph Feck 2011-07-19 22:59:41 UTC
Jeremy pushed a possible fix to 4.7 branch today. If it is still happening on 4.7.0, please add a comment.
Comment 10 Christoph Feck 2011-07-23 00:34:25 UTC
*** Bug 278300 has been marked as a duplicate of this bug. ***
Comment 11 S.Trzmiel 2011-08-11 10:33:28 UTC
Issue seems to be resolved in KDE 4.7.0 final