Bug 277747 - Tabwidget: problems with corner buttons in east/west tab mode and right to left layout
Summary: Tabwidget: problems with corner buttons in east/west tab mode and right to le...
Status: RESOLVED FIXED
Alias: None
Product: Oxygen
Classification: Unclassified
Component: style (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-14 09:00 UTC by Sune Vuorela
Modified: 2011-07-15 12:13 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot of the issue. (50.70 KB, image/jpeg)
2011-07-14 09:00 UTC, Sune Vuorela
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sune Vuorela 2011-07-14 09:00:05 UTC
Created attachment 61870 [details]
screenshot of the issue.

Version:           unspecified
OS:                Linux

The buttons appear in the wrong side when using east or west tabs in a tabwidfget, enabled corner buttons and right to left layout.

Reproducible: Didn't try

Steps to Reproduce:
try oxygen demo. set options as above

Actual Results:  
buttons in the wrong side.

Expected Results:  
buttons in the right side.
Comment 1 Christoph Feck 2011-07-15 10:48:24 UTC
Happens with every style => Qt bug. Please report this issue to Qt developers at http://bugreports.qt.nokia.com/
Comment 2 Christoph Feck 2011-07-15 10:50:38 UTC
Actually, Oxygen is the only style that works around the Qt bug, but does it wrong for the RTL option you mentioned.
Comment 3 Hugo Pereira Da Costa 2011-07-15 11:54:24 UTC
@Christoph
yeah exactly. For other styles there's no buttons at all (right ?)
I'll try find a better workaround in oxygen.
Comment 4 Hugo Pereira Da Costa 2011-07-15 12:11:53 UTC
Git commit d02b22d767dc77e4b1ff29af2014f9f5a338ecc4 by Hugo Pereira Da Costa.
Committed on 15/07/2011 at 14:06.
Pushed by hpereiradacosta into branch 'KDE/4.7'.

Do not call visualRect() when calculation TabWidget's corner button rects in West/East
orientation, because this is double counted (apparently already dealt with at the tabbar rect
level)

CCBUG: 277747

M  +0    -4    kstyles/oxygen/oxygenstyle.cpp     

http://commits.kde.org/kde-workspace/d02b22d767dc77e4b1ff29af2014f9f5a338ecc4
Comment 5 Hugo Pereira Da Costa 2011-07-15 12:11:53 UTC
Git commit 5531dcf27a1c176bde54b3f2df7bdf2f9386c7bf by Hugo Pereira Da Costa.
Committed on 15/07/2011 at 14:06.
Pushed by hpereiradacosta into branch 'master'.

Do not call visualRect() when calculation TabWidget's corner button rects in West/East
orientation, because this is double counted (apparently already dealt with at the tabbar rect
level)

CCBUG: 277747

M  +0    -4    kstyles/oxygen/oxygenstyle.cpp     

http://commits.kde.org/kde-workspace/5531dcf27a1c176bde54b3f2df7bdf2f9386c7bf
Comment 6 Hugo Pereira Da Costa 2011-07-15 12:13:20 UTC
Comments #4 and #5 fix the bug (in master and KDE/4.7)
In fact the commit comment is misleading though.
What really happen is that Tabbar tab orientation does not care about RLT languages (West is West disregarding the language direction), whereas I was accounting for it when placing the buttons.