Bug 277421 - KDE processes (plasma-desktop etc.) just listed as "kdeinit4:"
Summary: KDE processes (plasma-desktop etc.) just listed as "kdeinit4:"
Status: RESOLVED FIXED
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-09 14:38 UTC by Christoph Feck
Modified: 2011-07-10 18:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Hotfix (1.18 KB, patch)
2011-07-10 12:52 UTC, Mad Fish
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Feck 2011-07-09 14:38:04 UTC
Since a day or two, KDE processes started by kdeinit4 are just listed as "kdeinit4:" in the process table. I have to hover on the name to see the actual application/command name.
Comment 1 Mad Fish 2011-07-10 12:52:24 UTC
Created attachment 61758 [details]
Hotfix

This is regression due to my recent fix for long process names.
https://bugs.kde.org/show_bug.cgi?id=276958
Attaching hotfix patch.
Comment 2 Christoph Feck 2011-07-10 16:54:42 UTC
I can confirm that the patch from comment #1 fixes the issue. Long process names, such as "kactivitymanagerd" are not truncated either.
Comment 3 Christoph Feck 2011-07-10 18:56:44 UTC
Git commit cd32b63f6bc0a900ce57587ed30d7dabf60c4440 by Christoph Feck.
Committed on 10/07/2011 at 20:56.
Pushed by cfeck into branch 'master'.

Fix KDE process names shown as "kdeinit4:"

Patch by Alexander Chehovsky, thanks!
BUG: 277421

M  +3    -1    libs/ksysguard/processcore/processes_linux_p.cpp     

http://commits.kde.org/kde-workspace/cd32b63f6bc0a900ce57587ed30d7dabf60c4440
Comment 4 Albert Astals Cid 2011-07-10 18:58:36 UTC
Git commit 50f1bf7a4a90fde3a4a0454cb9d1540d9224dab5 by Albert Astals Cid, on behalf of Christoph Feck.
Committed on 10/07/2011 at 20:56.
Pushed by aacid into branch 'KDE/4.7'.

Fix KDE process names shown as "kdeinit4:"

Patch by Alexander Chehovsky, thanks!
BUG: 277421
(cherry picked from commit cd32b63f6bc0a900ce57587ed30d7dabf60c4440)

M  +3    -1    libs/ksysguard/processcore/processes_linux_p.cpp     

http://commits.kde.org/kde-workspace/50f1bf7a4a90fde3a4a0454cb9d1540d9224dab5