Bug 277279 - When entering the year in metadata the ordering of digits is messed up
Summary: When entering the year in metadata the ordering of digits is messed up
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Metadata Editing and Reading (show other bugs)
Version: 2.4.1
Platform: Ubuntu Packages Linux
: NOR minor (vote)
Target Milestone: 2.5
Assignee: Amarok Developers
URL:
Keywords:
: 284827 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-07 09:31 UTC by Gandalf Lechner
Modified: 2011-10-24 12:06 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gandalf Lechner 2011-07-07 09:31:38 UTC
Version:           2.4.1 (using KDE 4.6.4) 
OS:                Linux

When entering metadata for a track/album, there is a strange bug related to the "year" field: After entering the first digit (e.g. "2" when the year is "2008"), the cursor jumps in front of this digit. So typing 2008 results in 0082, or 1992 in 9921.

Reproducible: Always

Steps to Reproduce:
enter/edit metadata


Expected Results:  
enter the year as usual

OS: Linux (x86_64) release 2.6.38-10-generic
Compiler: cc
Comment 1 Myriam Schweingruber 2011-07-11 14:54:02 UTC
This only happens if you wait about a second or two before typing the second digit. I can confirm this behavior in this case. When typing the numbers in sequence without pausing it behaves correctly.
Comment 2 robert marshall 2011-07-30 13:51:03 UTC
I see this happening even if you don't pause when typing, so typing 1234 rapidly gives me 2341. It looks to me as if there's initially a space in the year field, if you click in the field the cursor gets placed (unless you're very careful) to the left of the space and I think it's this positioning that causes the problem - if you position the cursor to the right of the space the bug doesn't appear (for me anyway!) I also see this problem in other numeric fields - e.g. track number
Comment 3 Sergey Ivanov 2011-08-06 10:04:33 UTC
Git commit 31ac9be32c79403159c3be91a087ff6fa122d04c by Sergey Ivanov.
Committed on 06/08/2011 at 11:51.
Pushed by ivanov into branch 'master'.

Disabled keyboard tracking for TagDialog's SpinBoxes to fix the bug with messed typing order (caused by right text alignment).
BUG: 277279
FIXED-IN: 2.4.4

M  +9    -21   src/dialogs/TagDialogBase.ui

http://commits.kde.org/amarok/31ac9be32c79403159c3be91a087ff6fa122d04c
Comment 4 Myriam Schweingruber 2011-10-24 12:06:00 UTC
*** Bug 284827 has been marked as a duplicate of this bug. ***