Bug 276810 - coverswitch effect looks bad in 4.7
Summary: coverswitch effect looks bad in 4.7
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: effects-tabbox (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-30 09:45 UTC by Antonio Rojas
Modified: 2011-07-03 09:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Rojas 2011-06-30 09:45:18 UTC
Version:           unspecified (using Devel) 
OS:                Linux

In KDE 4.7, selecting a window from the cover switch effect looks bad. Instead of moving smoothly from the back position to the destkop as it did in 4.6, it seems to fade out to the desktop and then the windows appear suddenly.

Reproducible: Always

Steps to Reproduce:
Use the coverswitch effect to switch windows

Actual Results:  
the effect fades out and the the windows appear

Expected Results:  
when exiting the effect, the window moves smoothly to its position on the desktop as it did in 4.6
Comment 1 Martin Flöser 2011-07-03 09:09:01 UTC
Git commit cc9356a8274936f21f77c77cbc5fea83f3d42ddd by Martin Gräßlin.
Committed on 03/07/2011 at 11:07.
Pushed by graesslin into branch 'KDE/4.7'.

Fix a rendering glitch caused by the reflections in CoverSwitch

Seems like we need to use drawWindow instead of paintWindow or
KWin will keep some parts of the paint data.

BUG: 276810
FIXED-IN: 4.7.0

M  +1    -1    kwin/effects/coverswitch/coverswitch.cpp     

http://commits.kde.org/kde-workspace/cc9356a8274936f21f77c77cbc5fea83f3d42ddd