Bug 275413 - Groups should expand on single click
Summary: Groups should expand on single click
Status: RESOLVED FIXED
Alias: None
Product: telepathy
Classification: Unclassified
Component: contactlist (show other bugs)
Version: git-latest
Platform: Compiled Sources Linux
: NOR normal
Target Milestone: 0.4.0
Assignee: Telepathy Bugs
URL:
Keywords:
Depends on:
Blocks: tppreviewrelease
  Show dependency treegraph
 
Reported: 2011-06-11 18:18 UTC by Luis Silva
Modified: 2012-07-06 12:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Patch making the groups expand on single click (1.53 KB, patch)
2011-06-11 18:18 UTC, Luis Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Silva 2011-06-11 18:18:46 UTC
Created attachment 60908 [details]
Patch making the groups expand on single click

Version:           git-latest (using KDE 4.6.4) 
OS:                Linux

For usability and coherence with symilar lists in other kde apps, the groups in the contact list should expand on single click, not on double click as they are now.
I append a patch to do exactly this.

Reproducible: Always




OS: Linux (i686) release 2.6.38-9-generic
Compiler: cc
Comment 1 David Edmundson 2011-06-11 18:48:23 UTC
Agreed. Marked as new. 
Will implement if no-one else wants to.
Comment 2 David Edmundson 2011-06-12 22:03:15 UTC
Ok, just checked out your patch.

Whilst this does 'fix' groups you have also (unwittingly?) changed the behaviour of single clicking on a contact. 

I do /not/ think this should change, as it is all too easy to click on a user's name without wanting to start a text chat.
Comment 3 Luis Silva 2011-06-12 22:24:32 UTC
It was indeed unintentional but after using it for a while, it feels quite
natural to me. However, I agree that that might not be the intended
behavior. Just feel free to adapt the patch.

Luis Silva
On 12 Jun 2011 21:03, "David Edmundson" <kde@davidedmundson.co.uk> wrote:
> https://bugs.kde.org/show_bug.cgi?id=275413
>
>
>
>
>
> --- Comment #2 from David Edmundson <kde davidedmundson co uk> 2011-06-12
22:03:15 ---
> Ok, just checked out your patch.
>
> Whilst this does 'fix' groups you have also (unwittingly?) changed the
> behaviour of single clicking on a contact.
>
> I do /not/ think this should change, as it is all too easy to click on a
user's
> name without wanting to start a text chat.
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 4 Martin Klapetek 2011-06-12 22:26:53 UTC
Should we honor KDE's settings here (for the contact)?
Comment 5 Francesco Nwokeka 2011-06-17 23:11:50 UTC
Git commit b83e452e60969ee02891db835c715a88fac391db by Francesco Nwokeka.
Committed on 17/06/2011 at 23:13.
Pushed by nwokeka into branch 'master'.

FIX: single click to expand/collaps contact list groups

contact list groups are now expanded/collapsed by single click.

BUG: 275413
REVIEW: 101662
Reviewed by: David Edmundson

M  +19   -6    main-widget.cpp     
M  +1    -0    main-widget.h     

http://commits.kde.org/telepathy-contact-list/b83e452e60969ee02891db835c715a88fac391db