Bug 275119 - Blank page displaying before the Table of Contents
Summary: Blank page displaying before the Table of Contents
Status: VERIFIED FIXED
Alias: None
Product: calligrawords
Classification: Unclassified
Component: doc (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Calligra Words Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-07 14:37 UTC by swathi
Modified: 2011-09-02 11:27 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Test data (23.50 KB, application/octet-stream)
2011-06-07 14:37 UTC, swathi
Details
Screenshot in MS Office (130.39 KB, image/x-png)
2011-06-07 14:37 UTC, swathi
Details
Screenshot in Calligra Words (130.39 KB, image/x-png)
2011-06-07 14:38 UTC, swathi
Details
Screenshot in Latest Calligra Words (99.19 KB, image/png)
2011-08-24 08:57 UTC, swathi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description swathi 2011-06-07 14:37:04 UTC
Created attachment 60744 [details]
Test data

Version: git checkout 9a54655da37b07ee9e670d9f537a8922afc26030
        (Using KDE 4.5.5)                
     OS: Kubuntu 10.10
Test data is in word 2003 format which has TOC in it.
Open the same document in Calligra Words, check the display of the toc.

Expected outcome:
Toc should be displayed in the 1st page of the document.

Actual outcome:
Blank page is displaying in the 1st page.TOC is displaying in 2nd page.

Frequency:
Always.
Comment 1 swathi 2011-06-07 14:37:32 UTC
Created attachment 60745 [details]
Screenshot in MS Office
Comment 2 swathi 2011-06-07 14:38:15 UTC
Created attachment 60746 [details]
Screenshot in Calligra Words
Comment 3 Sebastian Sauer 2011-06-08 23:14:24 UTC
Fixed with 494cce447132ff6c6d7935b0c2690873e7e87386
Comment 4 swathi 2011-06-29 05:42:50 UTC
Tested in  5f6f9401b53343b140d2bae8587ec3a01f103fe1,still blank page is displaying before TOC.So reopening the bug.
Comment 5 Sebastian Sauer 2011-07-10 04:38:30 UTC
Cannot reproduce with current master. Looks as it was fixed meanwhile.
Comment 6 swathi 2011-07-12 12:20:41 UTC
Tested in  0a3741ba8dceae49bab1944cae45367fb8e87dce,issue is still observed.
Comment 7 Sebastian Sauer 2011-07-12 18:22:01 UTC
Cannot reproduce then. Can you please attach a screenshot from Calligra Words (the one above are both from MSO)? Thanks.
Comment 8 Camilla Boemann 2011-07-13 11:55:50 UTC
Wors for me too
Comment 9 swathi 2011-08-24 08:57:01 UTC
Created attachment 63098 [details]
Screenshot in Latest Calligra Words

Tested in deaa03a4fe170eb91319e75b213cc66c23af1ed8.
In this revision,blank page is displaying after the TOC.
So reopening the bug.
Comment 10 Sebastian Sauer 2011-08-30 11:49:40 UTC
Mark fixed again. 

@Swathi
The screenshot you attached at comment #9 does *NOT* display the ToC at the second page. The second page is empty! So, the ToC is displayed at the first page. That means this report is fixed. If there are new issues (not related to the case this bugreport is about - and which was fixed ~2 months ago) then please create a new report. One report per issue else we will have huge problems to progress. Thanks.
Comment 11 swathi 2011-09-02 11:27:27 UTC
Blank page is not displaying in dd267fba75fccccf66e6d485dbada7cea5301d0f.
So marking as Verified.
But TOC is displaying twice,it will be treated as a seperate bug.