Bug 274493 - Systray popupapplet plasmoids (like devicenotifier/networkmanagment) icons jump to the side of the notification icon on activation
Summary: Systray popupapplet plasmoids (like devicenotifier/networkmanagment) icons ju...
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-systemtray (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-30 03:11 UTC by blibberblubb
Modified: 2011-05-30 12:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description blibberblubb 2011-05-30 03:11:14 UTC
Version:           unspecified (using Devel) 
OS:                Linux

When clicking on either devicenotifier or the networkmanagment icon in the systray area, the Popupapplet gets shown. 
As soon as you leave the systray area with your mouse cursor, the icon of the popupapplet shown jumps to the left, to the side of the notification icon. This is confusing and makes it hard to dismiss the popupapplet again, since the icon isn't at the expected place anymore.

Reproducible: Always
Comment 1 Marco Martin 2011-05-30 12:23:43 UTC
Git commit 2be71236d8c57ccabd1a88b0340ddf7cd932c2b4 by Marco Martin.
Committed on 30/05/2011 at 12:21.
Pushed by mart into branch 'master'.

don't move stuff all the way to the left

BUG:274493

M  +2    -1    plasma/generic/applets/systemtray/core/task.cpp     

http://commits.kde.org/kde-workspace/2be71236d8c57ccabd1a88b0340ddf7cd932c2b4