Bug 274490 - Krunner’s size can be set to zero
Summary: Krunner’s size can be set to zero
Status: RESOLVED FIXED
Alias: None
Product: krunner
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-30 02:32 UTC by Kai Uwe Broulik
Modified: 2011-06-06 23:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
KRunners height was reduced to its (new) minimum and then something was searched (6.75 KB, image/png)
2011-06-06 22:58 UTC, Kai Uwe Broulik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2011-05-30 02:32:25 UTC
Version:           unspecified (using Devel) 
OS:                Linux

You can resize KRunner’s height to zero so the window merely disappears and you can only bring it back by killing krunner and restarting it. Then it works fine again.

Reproducible: Always
Comment 1 Aaron J. Seigo 2011-05-30 11:26:00 UTC
"You can resize KRunner’s height to zero"

it wasn't obvious how to reproduce; if you can, in future reports please include detailed reproduction steps so that triage time is faster and we don't close a report as "worksforme" because we can't figure out how to reproduce it. thanks...

(working on a fix)
Comment 2 Aaron J. Seigo 2011-05-30 12:13:15 UTC
Git commit c0de65db03fcecce20a9432003d1535a4ae74e6a by Aaron Seigo.
Committed on 30/05/2011 at 12:12.
Pushed by aseigo into branch 'master'.

prevent zero sizing the window

BUG:274490

M  +2    -2    krunner/interfaces/default/interface.cpp     

http://commits.kde.org/kde-workspace/c0de65db03fcecce20a9432003d1535a4ae74e6a
Comment 3 Kai Uwe Broulik 2011-05-30 12:45:44 UTC
Sorry Aaron, should‘ve written “KRunner can be sized so its size reaches zero” :) Thanks for the fix :)
Comment 4 Aaron J. Seigo 2011-05-30 13:48:59 UTC
actually, what would have been useful is something like this:

* set krunner's window to be 'free floating' in the configuration
* resize the window height using the mouse by clicking on the window edge
* note that the window can be resized to 0 height

the free floating bit was important (non-reproducable here with krunner docked to the top edge), and noting how the resize was done (e.g. not using the alt+f3 menu) was also useful.

cheers ..
Comment 5 Kai Uwe Broulik 2011-05-30 13:56:12 UTC
Well, I didn’t even consider/try that freefloating bit, I had it docked but now I cannot resize it to zero when docked either. So fixed anyway :)
Comment 6 Kai Uwe Broulik 2011-06-06 22:58:28 UTC
Created attachment 60716 [details]
KRunners height was reduced to its (new) minimum and then something was searched

Your fix introduced a regression: Automatic resizing when results become available does not work anymore.
When krunner is triggered, its height is the default startup height.
Enter something: It used to resize itself so it showed about 4 entries.
Now it resizes to the last set size no matter how small or big this is (I think there is a max of 1/2 screen height and of course the minimum to prevent it from being set to zero). So, if you resize krunner to its minimum (there have to be results in the list, if the list is empty, it won’t remember the height you resized it to), close it, re-open it and search for something, its input field will be smashed together with the results partially covering the borders thus making resizing it bigger hard. (I hope you understand what I mean, see attachment)

Make KRunner automatically adjust its height when results show up like it used to. Or better: Remember the last set size, so users can adjust the amount of items shown to their liking but set a minimum height of like 4 items.
Comment 7 Aaron J. Seigo 2011-06-06 23:24:25 UTC
"Automatic resizing when results become available does not work anymore."

this actually works here. occasionally i can trigger the behavior seen in your screenshot, but it isn't due to it not resizing on new items, but from what i've seen this only happens when i manually resize the window to be very small. so it's doing exactly what it is being told to do, but it is being told to do something silly.

i agree that it probably shouldn't be resizable below 1 item.
Comment 8 Kai Uwe Broulik 2011-06-06 23:33:25 UTC
It does resize once I enter something but to the size I have manually set, not to a preset default like before. But the new(?) behavior is definitly fine, it gives the user control about how many items he wishes to see. But yes, it shouldn’t be resizable below 1 item :)
Comment 9 Aaron J. Seigo 2011-06-06 23:38:54 UTC
Git commit 7deb7881515dc3cf43808e0bcdd547c4a9155965 by Aaron Seigo.
Committed on 06/06/2011 at 23:38.
Pushed by aseigo into branch 'master'.

bigger default minimum size; prevents squishies.

CCBUG:274490

M  +1    -1    krunner/krunnerdialog.cpp     

http://commits.kde.org/kde-workspace/7deb7881515dc3cf43808e0bcdd547c4a9155965