Bug 273549 - Black color boxes are displaying in the attached doc filie
Summary: Black color boxes are displaying in the attached doc filie
Status: VERIFIED FIXED
Alias: None
Product: calligrawords
Classification: Unclassified
Component: doc (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Matus Uzak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-18 10:37 UTC by swathi
Modified: 2011-06-11 16:26 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Test data (34.50 KB, application/octet-stream)
2011-05-18 10:37 UTC, swathi
Details
Screenshot in MS Office (242.17 KB, image/x-png)
2011-05-18 10:39 UTC, swathi
Details
Screenshot in Calligra Words (169.40 KB, image/x-png)
2011-05-18 10:40 UTC, swathi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description swathi 2011-05-18 10:37:44 UTC
Created attachment 60109 [details]
Test data

Version: git checkout 9b502d5b387f86a73505d25675762f08c8caf824
        (Using KDE 4.5.5)                
     OS: Kubuntu 10.10
Test data is in MS word 2003 format.
Open the same document in Calligra Words.
Expected outcome:
All the content in the document should be displayed properly.
Actual outcome:
Black color boxes are displaying.
Please check the screenshots attached.
Frequency:
Always.
Comment 1 swathi 2011-05-18 10:39:17 UTC
Created attachment 60110 [details]
Screenshot in MS Office
Comment 2 swathi 2011-05-18 10:40:28 UTC
Created attachment 60111 [details]
Screenshot in Calligra Words
Comment 3 Inge Wallin 2011-05-19 09:43:53 UTC
Without having checked, I suspect that this document is a good candidate for test document for section columns.
Comment 4 Matus Uzak 2011-05-25 10:40:16 UTC
The paragraph shading seems to be not set properly by the filter.
Comment 5 Matus Uzak 2011-06-03 21:11:17 UTC
I updated processing of the shading information, which is now shared for both tables and paragraphs.  In case of the problematic paragraphs the information is invalid and the problem is somewhere in decompression of built-in styles.  It's going to take a while to fix this issue.
Comment 6 Matus Uzak 2011-06-08 02:29:28 UTC
Git commit 8288143b7c1f9f9005209b55b651875219b0e9d6 by Matus Uzak.
Committed on 08/06/2011 at 02:25.
Pushed by uzak into branch 'master'.

DOC: Improvements in processing of the background shading.

* Sharing one conversion function that translates the shading information
  into a color in the format "#RRGGBB".
* Returning a reasonable default instead of shading patterns at the moment.
* Also some readability improvements.

BUG:273549

M  +52   -16   filters/words/msword-odf/conversion.cpp     
M  +12   -4    filters/words/msword-odf/conversion.h     
M  +4    -2    filters/words/msword-odf/document.h     
M  +8    -23   filters/words/msword-odf/paragraph.cpp     
M  +0    -6    filters/words/msword-odf/paragraph.h     
M  +2    -2    filters/words/msword-odf/tablehandler.cpp     
M  +4    -4    filters/words/msword-odf/wv2/src/convert.cpp     
M  +13   -5    filters/words/msword-odf/wv2/src/styles.cpp     
M  +6    -6    filters/words/msword-odf/wv2/src/word97_generated.cpp     
M  +2    -2    filters/words/msword-odf/wv2/src/word97_generated.h     
M  +6    -2    filters/words/msword-odf/wv2/src/word97_helper.cpp     

http://commits.kde.org/calligra/8288143b7c1f9f9005209b55b651875219b0e9d6
Comment 7 swathi 2011-06-11 16:26:49 UTC
Verified in 8288143b7c1f9f9005209b55b651875219b0e9d6 .