Bug 273491 - clicking the "new game" button in the scene editor whilst having the Apocolypse.gluon project loaded crashes Gluon Creator
Summary: clicking the "new game" button in the scene editor whilst having the Apocolyp...
Status: RESOLVED UNMAINTAINED
Alias: None
Product: gluon
Classification: Unclassified
Component: gluoncreator (show other bugs)
Version: Electron(alpha 2)
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Arjen Hiemstra
URL:
Keywords:
: 278354 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-17 17:01 UTC by Ryan Swart
Modified: 2020-11-10 13:03 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Swart 2011-05-17 17:01:22 UTC
Version:           Electron(alpha 2) (using KDE 4.6.2) 
OS:                Linux

Clicking the "new game" button in the scene editor whilst having the Apocolypse.gluon project loaded crashes Gluon Creator

Reproducible: Always

Steps to Reproduce:
Open gluon, load a local copy of the apocolypse, click the new game button in the scene editor

Actual Results:  
GluonCreator crashes

Expected Results:  
Nothing, or being able to edit the element
Comment 1 Laszlo Papp 2011-05-17 18:15:56 UTC
Thank you for your report, I can also reproduce it, here is the bt:

Application: Gluon Creator (gluoncreator), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fa64974e7a0 (LWP 17834))]

Thread 5 (Thread 0x7fa6301b6700 (LWP 17838)):
#0  0x00007fa643ea69dd in nanosleep () from /lib/libpthread.so.0
#1  0x00007fa634819973 in ?? () from /usr/lib/libopenal.so.1
#2  0x00007fa6347fcf3a in ?? () from /usr/lib/libopenal.so.1
#3  0x00007fa643e9ecb0 in start_thread () from /lib/libpthread.so.0
#4  0x00007fa64320f95d in clone () from /lib/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fa62b1b3700 (LWP 17839)):
#0  0x00007fa643ea69dd in nanosleep () from /lib/libpthread.so.0
#1  0x00007fa634365e5b in alureSleep () from /usr/lib/libalure.so.1
#2  0x00007fa63436adc8 in ?? () from /usr/lib/libalure.so.1
#3  0x00007fa63436a2ad in ?? () from /usr/lib/libalure.so.1
#4  0x00007fa643e9ecb0 in start_thread () from /lib/libpthread.so.0
#5  0x00007fa64320f95d in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fa62b9b4700 (LWP 17840)):
#0  0x00007fa643207533 in poll () from /lib/libc.so.6
#1  0x00007fa64266f134 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007fa64266f66d in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007fa648b44a66 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007fa648b18ca2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007fa648b18eec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007fa648a2e494 in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007fa648afa6a8 in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007fa648a30cf5 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007fa6470c5ae3 in ?? () from /usr/lib/libGL.so.1
#10 0x00007fa643e9ecb0 in start_thread () from /lib/libpthread.so.0
#11 0x00007fa64320f95d in clone () from /lib/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fa62cd0f700 (LWP 17841)):
#0  0x00007fa643ea334c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fa6479fe364 in ?? () from /usr/lib/libQtScript.so.4
#2  0x00007fa6479fe399 in ?? () from /usr/lib/libQtScript.so.4
#3  0x00007fa6470c5ae3 in ?? () from /usr/lib/libGL.so.1
#4  0x00007fa643e9ecb0 in start_thread () from /lib/libpthread.so.0
#5  0x00007fa64320f95d in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa64974e7a0 (LWP 17834)):
[KCrash Handler]
#6  0x00007fa6484daa21 in ?? () from /usr/lib/libQtGui.so.4
#7  0x00007fa6484dafa4 in QGraphicsScene::mousePressEvent(QGraphicsSceneMouseEvent*) () from /usr/lib/libQtGui.so.4
#8  0x00007fa6484e489f in QGraphicsScene::event(QEvent*) () from /usr/lib/libQtGui.so.4
#9  0x00007fa647ede6a4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#10 0x00007fa647ee326a in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#11 0x00007fa646288d46 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#12 0x00007fa648b1990c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#13 0x00007fa62ef5ee78 in GluonEngine::RenderableScene::deliverEvent (this=0x2ae3260, event=0x7fff9c054210) at /home/lpapp/Projects/kde/gluon/engine/components/graphics/uimanager/renderablescene.cpp:195
#14 0x00007fa62ef5f23e in GluonEngine::RenderableScene::qt_metacall (this=0x2ae3260, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff9c053910) at /home/lpapp/Projects/kde/gluon/build/engine/components/graphics/uimanager/renderablescene.moc:79
#15 0x00007fa648b2ee0f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#16 0x00007fa630837f7b in GluonInput::InputManager::eventFiltered (this=0x24ca270, _t1=0x7fff9c054210) at /home/lpapp/Projects/kde/gluon/build/input/inputmanager.moc:125
#17 0x00007fa6308374b9 in GluonInput::InputManager::eventFilter (this=0x24ca270, object=0x2ae58e0, event=0x7fff9c054210) at /home/lpapp/Projects/kde/gluon/input/inputmanager.cpp:257
#18 0x00007fa648b19a97 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#19 0x00007fa647ede671 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0x00007fa647ee3aea in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0x00007fa646288d46 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0x00007fa648b1990c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0x00007fa647edf6b5 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
#24 0x00007fa647f5e618 in ?? () from /usr/lib/libQtGui.so.4
#25 0x00007fa647f5ccd9 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#26 0x00007fa647f84392 in ?? () from /usr/lib/libQtGui.so.4
#27 0x00007fa64266ebf3 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#28 0x00007fa64266f3d0 in ?? () from /usr/lib/libglib-2.0.so.0
#29 0x00007fa64266f66d in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#30 0x00007fa648b44a0f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0x00007fa647f8403e in ?? () from /usr/lib/libQtGui.so.4
#32 0x00007fa648b18ca2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#33 0x00007fa648b18eec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#34 0x00007fa648b1d3eb in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#35 0x000000000040e73f in main (argc=1, argv=0x7fff9c055238) at /home/lpapp/Projects/kde/gluon/creator/main.cpp:74
Comment 2 Laszlo Papp 2011-07-24 00:32:53 UTC
*** Bug 278354 has been marked as a duplicate of this bug. ***
Comment 3 Laszlo Papp 2011-08-08 12:23:54 UTC
Git commit be7bbaa0b6294362fc999d68538fd50b50468959 by Laszlo Papp.
Committed on 08/08/2011 at 17:22.
Pushed by lpapp into branch 'master'.

Fix the crash while clicking on the in-game ui without playing the game

BUG: 273491

M  +5    -1    engine/components/graphics/uimanager/renderablescene.cpp

http://commits.kde.org/gluon/be7bbaa0b6294362fc999d68538fd50b50468959
Comment 4 Laszlo Papp 2012-03-17 18:29:14 UTC
After the revert, it is still reproducible, if creator runs as "user".