Bug 272900 - i18n of strings in nepomukstrigiservice doesn't work
Summary: i18n of strings in nepomukstrigiservice doesn't work
Status: RESOLVED FIXED
Alias: None
Product: nepomuk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-10 02:01 UTC by Lasse Liehu
Modified: 2011-06-08 09:14 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Load the service cataloge in the service stub. (448 bytes, patch)
2011-05-30 10:32 UTC, Sebastian Trueg
Details
Update to load the service catalog in the service stub. (799 bytes, patch)
2011-06-05 05:26 UTC, Lasse Liehu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lasse Liehu 2011-05-10 02:01:20 UTC
Version:           unspecified (using Devel) 
OS:                Linux

Messages like "File indexer is idle" and "Strigi is currently indexing files in folder %1" aren't translated in kcm_nepomuk. Also the notification "Initial indexing of files for fast searching finished in %1" isn't translated.

Tested that adding KGlobal::locale()->insertCatalog("nepomukstrigiservice"); in Nepomuk::StrigiService::StrigiService in nepomuk/services/strigi/strigiservice.cpp fixes this.

Reproducible: Didn't try

Steps to Reproduce:
1. Open kcm_nepomuk using the x-test language.
Comment 1 Sebastian Trueg 2011-05-30 10:31:38 UTC
While I can reproduce the bug I cannot reproduce the fix (although I understand it to be perfectly fine). Could you please test the attached patch to see if it fixes the problem for you, too (without the patch you propose).
Comment 2 Sebastian Trueg 2011-05-30 10:32:19 UTC
Created attachment 60462 [details]
Load the service cataloge in the service stub.
Comment 3 Lasse Liehu 2011-06-05 05:26:21 UTC
Created attachment 60642 [details]
Update to load the service catalog in the service stub.

Yes, found out that it didn't quite work (only after reporting, though).

Anyway, this makes your patch work for me.
Comment 4 Sebastian Trueg 2011-06-08 09:13:01 UTC
Git commit 75b5ab1cff55dd76949361bc7bed66a18b5e3de4 by Sebastian Trueg.
Committed on 08/06/2011 at 09:10.
Pushed by trueg into branch 'master'.

Use the correct cataloge for the stub app itself and the service.

Thanks go to Lasse Liehu for the patch which loads the cataloge for the
started service and, thus, makes sure messages from the file indexer
service are translated.
BUG: 272900

M  +3    -1    nepomuk/servicestub/main.cpp     

http://commits.kde.org/kde-runtime/75b5ab1cff55dd76949361bc7bed66a18b5e3de4
Comment 5 Sebastian Trueg 2011-06-08 09:14:35 UTC
Git commit ef113c527089becd0658670c6f32453dba723e59 by Sebastian Trueg.
Committed on 08/06/2011 at 09:10.
Pushed by trueg into branch 'KDE/4.6'.

Backport: Use the correct cataloge for the stub app itself and the service.

Thanks go to Lasse Liehu for the patch which loads the cataloge for the
started service and, thus, makes sure messages from the file indexer
service are translated.
BUG: 272900

M  +3    -1    nepomuk/servicestub/main.cpp     

http://commits.kde.org/kde-runtime/ef113c527089becd0658670c6f32453dba723e59