Bug 271091 - [PATCH] RPM spec syntax highlighting: error with multi line macros
Summary: [PATCH] RPM spec syntax highlighting: error with multi line macros
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: syntax (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 249318 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-16 13:10 UTC by urwald
Modified: 2011-07-22 12:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
The patch (28.31 KB, patch)
2011-04-16 13:10 UTC, urwald
Details
rpmspec.xml.old (28.65 KB, application/x-trash)
2011-04-16 13:11 UTC, urwald
Details
rpmspec.xml.new (27.71 KB, text/xml)
2011-04-16 13:12 UTC, urwald
Details

Note You need to log in before you can comment on or make changes to this bug.
Description urwald 2011-04-16 13:10:49 UTC
Created attachment 59034 [details]
The patch

Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

RPM spec syntax highlighting: error with multi line macros

Reproducible: Always

Steps to Reproduce:
When defining multi line macros and the following line is empty, then the next but one line is treated also as macro - but that is wrong.

Example:

%define my_multi_line_macro content1\
content2\
content3\

Release: 1

Actual Results:  
The text "Release: 1" is highlighted as macro content.

Expected Results:  
It should be highlighted as tag.

I've attached a patch. This patch

- fixes the issue that is described here
- fixes bug 249318
- fixes syntax highlighting in the %package section for lines that start with a macro (was formaly highlighted as an error, but should show just normal highlighting)

The patch is against rpmspec.xml that comes with KDE 4.6.0. I've checked the new rpmspec.xml against language.dtd and it is okay.
Comment 1 urwald 2011-04-16 13:11:25 UTC
Created attachment 59035 [details]
rpmspec.xml.old
Comment 2 urwald 2011-04-16 13:12:45 UTC
Created attachment 59037 [details]
rpmspec.xml.new
Comment 3 urwald 2011-04-16 13:14:08 UTC
*** Bug 249318 has been marked as a duplicate of this bug. ***
Comment 4 Dominik Haumann 2011-04-16 13:20:39 UTC
Git commit 95430b571b446c1673374f25a8ff9e3d17e9e312 by Dominik Haumann.
Committed on 16/04/2011 at 13:26.
Pushed by dhaumann into branch 'master'.

RPM spec update by Tim Fechtner

BUG: 271091

M  +15   -33   part/syntax/data/rpmspec.xml     

http://commits.kde.org/kate/95430b571b446c1673374f25a8ff9e3d17e9e312
Comment 5 urwald 2011-04-16 13:28:25 UTC
Thanks for fast apply :-)