Bug 271054 - JuK Tag Guesser ignores directory if Tag Editor is open
Summary: JuK Tag Guesser ignores directory if Tag Editor is open
Status: RESOLVED FIXED
Alias: None
Product: juk
Classification: Applications
Component: general (show other bugs)
Version: 3.4.2 (KDE 4.4.5)
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Scott Wheeler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-15 21:03 UTC by phezzan0
Modified: 2011-04-25 04:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.6.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description phezzan0 2011-04-15 21:03:51 UTC
Version:           3.4.2 (KDE 4.4.5) (using KDE 4.4.5) 
OS:                Linux

Let's say you have music organized into directories by Artist:

Foo Fighters/Album - Song - 1.mp3

And in the Tag Guesser configuration you make sure that it understands:
%a/%A - %t - %T

If the Tag Editor is not showing it works.
If the Tag EDitor is showing, Tag Guesser assumes the First Artist in the Entire collection and the corresponding Album name

Since the Tag Guesser runs after rename (another bug IMHO) renameing files with the Tag Editor open destroys the tag information.

Reproducible: Always

Steps to Reproduce:
Pick any file, open the tag editor, press ^G (assuming default shortcuts)

Actual Results:  
File is retagged with the first Artist in the collection and corresponding Album

Expected Results:  
Tagger runs normally - guessing artist and album from the file name.

OS: Linux (x86_64) release 2.6.32-31-generic
Compiler: cc
Comment 1 Michael Pyne 2011-04-25 04:28:52 UTC
SVN commit 1229044 by mpyne:

Refresh tag editor if collection is updated while visible.

The indefatigable Giorgos Kylafas managed to troubleshoot the cause of a bug
where the Tag Editor's artist, genre, and track name fields would be reset to
the first item in the respective combo boxes after the collection was updated,
although this behavior only occurred if the tag editor was visible when it
happened.

I would say this should have tipped me off, but I haven't had enough time for
JuK recently so honestly I haven't looked at it. Giorgos has, however, and I
can confirm he tracked down the issue correctly and fixed it.

Going through the bugs seems to indicate this might be the cause of 271054
(JuK tag guesser works improperly if tag editor is open), which I believe is
caused the the tag editor being updated when the file renamer operates,
immediately updating the relevant fields to the wrong values and (somehow?)
then saving those changes.

This commit is against trunk, I will backport to 4.6.3.

CCBUG:271054
CCMAIL:gekylafas@gmail.com


 M  +4 -1      tageditor.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1229044
Comment 2 Michael Pyne 2011-04-25 04:40:04 UTC
SVN commit 1229047 by mpyne:

Backport proper tag editor updating to 4.6.3.

Full details are in the commit message for the relevant trunk commit
(r1229044), but this commit essentially properly updates the tag editor on
collection changes so that the displayed title, artist, and genre still
reflect the selected tracks. A bug prior to this fix reset those fields to the
first value in their respective list of possibilities.

This effect does not play well with file renaming, so I believe this also
fixes 271054 (or at least I cannot reproduce it) and the possibly-duplicate
bug 264092 (which would be a dup of 271054 if Michał's genre list had an
empty genre as its first entry). I also cannot reproduce 264092 with this fix,
so please reopen if I've closed the bugs too hastily.

And before I forget: The issue was identified and fixed by Giorgos Kylafas, so
send your thanks (if any) his way. ;)

In case it isn't clear, the 4.6.3 refers to the KDE compilation release, not
the internal JuK version.

CCMAIL:gekylafas@gmail.com
BUG:264092
BUG:271054
FIXED-IN:4.6.3


 M  +4 -1      tageditor.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1229047