Bug 270751 - QProgressBar busy animation not working in Oxygen style
Summary: QProgressBar busy animation not working in Oxygen style
Status: RESOLVED FIXED
Alias: None
Product: Oxygen
Classification: Unclassified
Component: style (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-12 11:41 UTC by Jan
Modified: 2011-04-12 19:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan 2011-04-12 11:41:10 UTC
Version:           unspecified (using KDE 4.6.2) 
OS:                Linux

Oxygen style does not animate a QProgressBar that is set to be a busy indicator.

Reproducible: Always

Steps to Reproduce:
1) Open Qt Designer and create a widget
2) Add several QProgressBar widgets
3) Set minimum and maximum properties of all progress bars to 0
4) Set random values for different progress bars to the value property
5) Preview the widget with Oxygen Style and observe that progress bars aren't animated
6) Preview in another widget style and observe that all progress bars are animated



The same applies when writing a small test program - testing it with Qt Designer is just faster. Also note that using GTK+ style, with the actual GTK+ style being oxygen-gtk, progress bars are animated.
Comment 1 Hugo Pereira Da Costa 2011-04-12 11:56:10 UTC
... I'm confused. 
If you type oxygen-demo (from konsole, or terminal), and go to the "slider" tab, there is an animated progressbar there. 

Are you saying that it is not working in designer-preview only, but actually is working on the executable program ? 

Or is not working on both (which is then in contradiction with oxygen-demo).

Also note that at least for me, it is also working with e.g. kmail statusbar.
Comment 2 Hugo Pereira Da Costa 2011-04-12 11:56:43 UTC
(PS: oxygen-gtk is totally unrelated here. Completely independent code path).
Comment 3 Hugo Pereira Da Costa 2011-04-12 12:00:40 UTC
Hint:

Could you 
- type "oxygen-settings" from konsole, or krunner; 
- in the first page, go to the "animations" tab
- make sure the line "Busy indicator steps" is checked
- click on the "tools" icon button, and check the "Duration" value, making sure its not 0.

This "advanced" settings are supposed to control busy progressbar animation.
Comment 4 Hugo Pereira Da Costa 2011-04-12 12:01:21 UTC
(you'd also need to make sure that the first "Enable animations" checkbox is indeed checked).
Comment 5 Hugo Pereira Da Costa 2011-04-12 14:02:07 UTC
Git commit 2997e73a3a392b60c46f88656301e527a12cbcda by Hugo Pereira Da Costa.
Committed on 12/04/2011 at 14:03.
Pushed by hpereiradacosta into branch 'KDE/4.6'.

Do not condition "busy" progressbar animation by the global "enable animations" flag.
They must be disabled explicitely via oxygen-settings.

CCBUG: 270751

Conflicts:

	kstyles/oxygen/animations/oxygenanimations.cpp

M  +1    -1    kstyles/oxygen/animations/oxygenanimations.cpp     

http://commits.kde.org/kde-workspace/2997e73a3a392b60c46f88656301e527a12cbcda
Comment 6 Hugo Pereira Da Costa 2011-04-12 14:02:07 UTC
Git commit 93fc6c4298e7141b5673c2ab4b78d908ac34767f by Hugo Pereira Da Costa.
Committed on 12/04/2011 at 12:39.
Pushed by hpereiradacosta into branch 'master'.

Do not condition "busy" progressbar animation by the global "enable animations" flag.
They must be disabled explicitely via oxygen-settings.

CCBUG: 270751

M  +1    -1    kstyles/oxygen/animations/oxygenanimations.cpp     

http://commits.kde.org/kde-workspace/93fc6c4298e7141b5673c2ab4b78d908ac34767f
Comment 7 Jan 2011-04-12 19:30:01 UTC
You're right, I've disabled animations altogether. I must say that it is rather odd that busy indicator animation can be disabled since it makes a progress bar used in that way do nothing - suggesting that nothing is being done.
Comment 8 Hugo Pereira Da Costa 2011-04-12 19:39:53 UTC
" I must say that it is rather
odd that busy indicator animation can be disabled since it makes a progress bar
used in that way do nothing - suggesting that nothing is being done."

I agree. And in fact the commits referred to in comments 5 and 6 address exactly this. (one commit is to the master branch and another one if for next release of KDE4.6). 

The new behavior is that disabling animations as a whole do *not* disable the busy indicator any more (and I changed the UI of oxygen settings to make that explicit), and you would have to un-check it explicitly, to get the animation stopped.

So. The bug is fixed "twice", now.

Thanks for reporting !